summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-09 17:36:03 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-09 18:18:38 +0200
commit81436a875a39e0afaf17f500b50b1b7d20e92602 (patch)
treecee8cf79dac4093ca2c21d654235e6b70aa05c7b /net-libs/ortp
parentmedia-video/kaffeine: version bump (diff)
downloadgentoo-81436a875a39e0afaf17f500b50b1b7d20e92602.tar.gz
gentoo-81436a875a39e0afaf17f500b50b1b7d20e92602.tar.bz2
gentoo-81436a875a39e0afaf17f500b50b1b7d20e92602.zip
net-libs/ortp: Support libressl (#565236)
Package-Manager: portage-2.3.1
Diffstat (limited to 'net-libs/ortp')
-rw-r--r--net-libs/ortp/ortp-0.23.0-r1.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/net-libs/ortp/ortp-0.23.0-r1.ebuild b/net-libs/ortp/ortp-0.23.0-r1.ebuild
new file mode 100644
index 000000000000..bdc1b15df7d5
--- /dev/null
+++ b/net-libs/ortp/ortp-0.23.0-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Open Real-time Transport Protocol (RTP, RFC3550) stack"
+HOMEPAGE="http://www.linphone.org/"
+SRC_URI="mirror://nongnu/linphone/${PN}/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/9"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+
+IUSE="debug doc examples ipv6 libressl minimal ntp-timestamp ssl srtp zrtp"
+REQUIRED_USE="zrtp? ( srtp )"
+
+RDEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= ) )
+ srtp? ( net-libs/libsrtp:0= )
+ zrtp? ( >=net-libs/libzrtpcpp-4.0.0:0= )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ # ${P} is added after ${docdir}
+ if use doc; then
+ sed -i -e 's/$(docdir)\/$(PACKAGE)-$(VERSION)/$(docdir)/' Makefile.in \
+ || die "patching Makefile.in failed"
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ # memcheck is for HP-UX only
+ --disable-memcheck
+ # mode64bit adds +DA2.0W +DS2.0 CFLAGS wich are needed for HP-UX
+ --disable-mode64bit
+ # strict adds -Werror, do not want it
+ --disable-strict
+ # they seriously failed to understand AC_ARG_ENABLE...
+ --disable-tests_enabled
+ --enable-fast-install
+ --enable-libtool-lock
+ # this is fine as long as we do not link to polarssl
+ --enable-broken-srtp
+
+ $(use_enable debug)
+ $(use_enable ipv6)
+ $(use_enable minimal perf)
+ $(use_enable ntp-timestamp)
+ $(use_enable ssl ssl-hmac)
+ $(use_enable zrtp)
+
+ --with-srtp=$(usex srtp "${EPREFIX}"/usr none)
+ $(use doc || echo ac_cv_path_DOXYGEN=false)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdocdir="${EPREFIX}"/usr/share/doc/${PF} \
+ install
+
+ einstalldocs
+
+ prune_libtool_files
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins src/tests/*.c
+ fi
+}