summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/osptoolkit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/osptoolkit')
-rw-r--r--net-libs/osptoolkit/Manifest2
-rw-r--r--net-libs/osptoolkit/metadata.xml11
-rw-r--r--net-libs/osptoolkit/osptoolkit-3.5.0.ebuild94
-rw-r--r--net-libs/osptoolkit/osptoolkit-4.1.5.ebuild94
4 files changed, 201 insertions, 0 deletions
diff --git a/net-libs/osptoolkit/Manifest b/net-libs/osptoolkit/Manifest
new file mode 100644
index 000000000000..e8e047e8b423
--- /dev/null
+++ b/net-libs/osptoolkit/Manifest
@@ -0,0 +1,2 @@
+DIST OSPToolkit-3.5.0.tar.gz 393788 SHA256 b15e2b8deec032c1e12dcbf28e2fe2b3f964ebab647e0705ec051bf17932d7b1
+DIST OSPToolkit-4.1.5.tar.gz 408481 SHA256 a0bf3247494375e63a75b4520c5c9aaaa0ed1423df54a013598c83a95846fccf SHA512 cc6244c0a62167ce90c85e646b13c991cac6d3663888ca4738666675f3c6c4904463e8502de376eab40cfd89e1d5c3d208d4ccaa58a95ed7a5895d74ea31aecc WHIRLPOOL 86111ab57301cf056a0ae9da56ce6a3bf2bbfcdd3c590f2447985420f204321a7e92ae747d2abae8e27d80e500f364f4982395311547c903de00eeaf1eef1d91
diff --git a/net-libs/osptoolkit/metadata.xml b/net-libs/osptoolkit/metadata.xml
new file mode 100644
index 000000000000..f6e0bd03f5ae
--- /dev/null
+++ b/net-libs/osptoolkit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">osp-toolkit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-libs/osptoolkit/osptoolkit-3.5.0.ebuild b/net-libs/osptoolkit/osptoolkit-3.5.0.ebuild
new file mode 100644
index 000000000000..b19794eb3d1f
--- /dev/null
+++ b/net-libs/osptoolkit/osptoolkit-3.5.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils multilib toolchain-funcs
+
+S_DATE="20090302"
+
+DESCRIPTION="Open Settlement Protocol development kit"
+HOMEPAGE="http://www.transnexus.com/OSP%20Toolkit/OSP%20Toolkit%20Documents/OSP%20Toolkit%20Documents.htm"
+SRC_URI="mirror://sourceforge/osp-toolkit/OSPToolkit-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/TK-${PV//./_}-${S_DATE}
+
+# TODO:
+# generate a shared lib
+
+# NOTES:
+# osptest isn't a test that can be used for src_test, it's part of the toolkit
+
+src_prepare() {
+ # remove -O and use users CFLAGS, see bug 241034
+ sed -i -e "s/ -O//" -e "s/^CFLAGS =/CFLAGS +=/" src/Makefile test/Makefile \
+ enroll/Makefile || die "patching Makefiles failed"
+
+ # use users LDFLAGS
+ sed -i -e "s:LFLAGS:LDFLAGS:" test/Makefile \
+ || die "patching test/Makefile failed"
+ sed -i -e "s:\(\$(LIBS\):\$(LDFLAGS) \1:" enroll/Makefile \
+ || die "patching enroll/Makefile failed"
+
+ # change lib dir to $(get_libdir)
+ sed -i -e "s:\$(INSTALL_PATH)/lib:\$(INSTALL_PATH)/$(get_libdir):" \
+ src/Makefile || die "patching src/Makefile failed"
+
+ # test.cfg is located in /etc/${PN}/test.cfg
+ sed -i -e \
+ "s:\(^#define CONFIG_FILENAME.*\"\).*\(test.cfg\"\):\1/etc/${PN}/\2:" \
+ test/test_app.c || die "patching test/test_app.c failed"
+
+ # configure enroll.sh
+ sed -i -e "s:^\(OPENSSL_CONF\).*:\1=/etc/${PN}/openssl.cnf:" \
+ -e "s:^\(RANDFILE\).*:\1=\/etc/${PN}/.rnd:" \
+ bin/enroll.sh || die "patching bin/enroll.sh failed"
+
+ # change enroll path
+ sed -i -e "s:^\(enroll\):/usr/lib/${PN}/\1:" \
+ bin/enroll.sh || die "patching bin/enroll.sh failed"
+}
+
+src_compile() {
+ local my_cc=$(tc-getCC)
+
+ emake -C src CC="${my_cc}" build || die "emake libosp failed"
+ emake -C enroll CC="${my_cc}" linux || die "emake enroll failed"
+ emake -C test CC="${my_cc}" linux || die "emake test failed"
+}
+
+src_install() {
+ local ospdir="/usr/$(get_libdir)/${PN}"
+
+ emake -C src INSTALL_PATH="${D}"/usr install || die "emake install failed"
+
+ insinto /etc/${PN}
+ doins bin/test.cfg bin/.rnd bin/openssl.cnf || die "doins failed"
+
+ # install enroll and enroll.sh in lib dir to prevent executing them
+ dodir ${ospdir}
+ exeinto ${ospdir}
+ doexe bin/enroll bin/enroll.sh || die "doexe failed"
+
+ # use the symlink to execute enroll.sh
+ dosym ${ospdir}/enroll.sh /usr/bin/ospenroll || die "dosym failed"
+
+ newbin bin/test_app osptest || die "newbin failed"
+
+ dodoc README.txt RELNOTES.txt || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "OSP test application is now available with 'osptest' command"
+ elog "OSP enroll application is now available with 'ospenroll' command"
+ elog "ospenroll is using /etc/${PN}/openssl.cnf as an openssl configuration"
+}
diff --git a/net-libs/osptoolkit/osptoolkit-4.1.5.ebuild b/net-libs/osptoolkit/osptoolkit-4.1.5.ebuild
new file mode 100644
index 000000000000..c97becdbf499
--- /dev/null
+++ b/net-libs/osptoolkit/osptoolkit-4.1.5.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils multilib toolchain-funcs
+
+S_DATE="20130819"
+
+DESCRIPTION="Open Settlement Protocol development kit"
+HOMEPAGE="http://www.transnexus.com/OSP%20Toolkit/OSP%20Toolkit%20Documents/OSP%20Toolkit%20Documents.htm"
+SRC_URI="mirror://sourceforge/osp-toolkit/OSPToolkit-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/TK-${PV//./_}-${S_DATE}
+
+# TODO:
+# generate a shared lib
+
+# NOTES:
+# osptest isn't a test that can be used for src_test, it's part of the toolkit
+
+src_prepare() {
+ # remove -O and use users CFLAGS, see bug 241034
+ sed -i -e "s/ -O//" -e "s/^CFLAGS =/CFLAGS +=/" src/Makefile test/Makefile \
+ enroll/Makefile || die "patching Makefiles failed"
+
+ # use users LDFLAGS
+ sed -i -e "s:LFLAGS:LDFLAGS:" test/Makefile \
+ || die "patching test/Makefile failed"
+ sed -i -e "s:\(\$(LIBS\):\$(LDFLAGS) \1:" enroll/Makefile \
+ || die "patching enroll/Makefile failed"
+
+ # change lib dir to $(get_libdir)
+ sed -i -e "s:\$(INSTALL_PATH)/lib:\$(INSTALL_PATH)/$(get_libdir):" \
+ src/Makefile || die "patching src/Makefile failed"
+
+ # test.cfg is located in /etc/${PN}/test.cfg
+ sed -i -e \
+ "s:\(^#define CONFIG_FILENAME.*\"\).*\(test.cfg\"\):\1/etc/${PN}/\2:" \
+ test/test_app.c || die "patching test/test_app.c failed"
+
+ # configure enroll.sh
+ sed -i -e "s:^\(OPENSSL_CONF\).*:\1=/etc/${PN}/openssl.cnf:" \
+ -e "s:^\(RANDFILE\).*:\1=\/etc/${PN}/.rnd:" \
+ bin/enroll.sh || die "patching bin/enroll.sh failed"
+
+ # change enroll path
+ sed -i -e "s:^\(enroll\):/usr/lib/${PN}/\1:" \
+ bin/enroll.sh || die "patching bin/enroll.sh failed"
+}
+
+src_compile() {
+ local my_cc=$(tc-getCC)
+
+ emake -C src CC="${my_cc}" build || die "emake libosp failed"
+ emake -C enroll CC="${my_cc}" linux || die "emake enroll failed"
+ emake -C test CC="${my_cc}" linux || die "emake test failed"
+}
+
+src_install() {
+ local ospdir="/usr/$(get_libdir)/${PN}"
+
+ emake -C src INSTALL_PATH="${D}"/usr install || die "emake install failed"
+
+ insinto /etc/${PN}
+ doins bin/test.cfg bin/.rnd bin/openssl.cnf || die "doins failed"
+
+ # install enroll and enroll.sh in lib dir to prevent executing them
+ dodir ${ospdir}
+ exeinto ${ospdir}
+ doexe bin/enroll bin/enroll.sh || die "doexe failed"
+
+ # use the symlink to execute enroll.sh
+ dosym ${ospdir}/enroll.sh /usr/bin/ospenroll || die "dosym failed"
+
+ newbin bin/test_app osptest || die "newbin failed"
+
+ dodoc README.txt RELNOTES.txt || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "OSP test application is now available with 'osptest' command"
+ elog "OSP enroll application is now available with 'ospenroll' command"
+ elog "ospenroll is using /etc/${PN}/openssl.cnf as an openssl configuration"
+}