summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/pacparser/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/pacparser/files')
-rw-r--r--net-libs/pacparser/files/pacparser-1.3.1-makefile.patch66
1 files changed, 66 insertions, 0 deletions
diff --git a/net-libs/pacparser/files/pacparser-1.3.1-makefile.patch b/net-libs/pacparser/files/pacparser-1.3.1-makefile.patch
new file mode 100644
index 000000000000..a1434075d18a
--- /dev/null
+++ b/net-libs/pacparser/files/pacparser-1.3.1-makefile.patch
@@ -0,0 +1,66 @@
+diff -Nur pacparser-1.3.1.orig/src/Makefile pacparser-1.3.1/src/Makefile
+--- pacparser-1.3.1.orig/src/Makefile 2013-11-26 04:21:24.000000000 +0000
++++ pacparser-1.3.1/src/Makefile 2013-11-26 04:27:11.000000000 +0000
+@@ -55,7 +55,7 @@
+ endif
+ endif
+
+-CFLAGS = -g -DXP_UNIX -Wall -DVERSION=$(VERSION)
++CFLAGS := $(CFLAGS) -g -DXP_UNIX -Wall -DVERSION=$(VERSION)
+
+ ifndef PYTHON
+ PYTHON = python
+@@ -67,13 +67,14 @@
+
+ LIBRARY_LINK = $(LIBRARY_NAME).$(SO_SUFFIX)
+ PREFIX := $(DESTDIR)$(PREFIX)
+-LIB_PREFIX = $(PREFIX)/lib
+-INC_PREFIX = $(PREFIX)/include
+-BIN_PREFIX = $(PREFIX)/bin
+-MAN_PREFIX = $(PREFIX)/share/man
++LIB_PREFIX := $(PREFIX)/lib
++INC_PREFIX := $(PREFIX)/include
++BIN_PREFIX := $(PREFIX)/bin
++MAN_PREFIX := $(PREFIX)/share/man
++DOC_PREFIX := $(PREFIX)/share/doc/pacparser
+
+ .PHONY: clean pymod install-pymod
+-all: testpactester
++all: pactester
+
+ spidermonkey/js/src: spidermonkey/js-?.?.?.tar.gz
+ tar xzvf spidermonkey/js-?.?.?.tar.gz -C spidermonkey
+@@ -97,7 +98,7 @@
+ ln -sf $(LIBRARY) $(LIBRARY_LINK)
+
+ pactester: pactester.c pacparser.h $(LIBRARY_LINK)
+- $(CC) pactester.c -o pactester -lpacparser -L. -I.
++ $(CC) $(CFLAGS) $(LDFLAGS) pactester.c -o pactester -lpacparser -L. -I.
+
+ testpactester: pactester
+ echo "Running tests for pactester."
+@@ -118,16 +119,20 @@
+ # install pacparser manpages
+ install -d $(MAN_PREFIX)/man3/
+ (test -d ../docs && install -m 644 ../docs/man/man3/*.3 $(MAN_PREFIX)/man3/) || true
++
++install-docs:
+ # install html docs
+- install -d $(PREFIX)/share/doc/pacparser/html/
+- (test -d ../docs/html && install -m 644 ../docs/html/* $(PREFIX)/share/doc/pacparser/html/) || true
++ install -d $(DOC_PREFIX)/html/
++ (test -d ../docs/html && install -m 644 ../docs/html/* $(DOC_PREFIX)/html/) || true
+ # install examples
+- install -d $(PREFIX)/share/doc/pacparser/examples/
+- (test -d ../examples && install -m 644 ../examples/* $(PREFIX)/share/doc//pacparser/examples/) || true
++ install -d $(DOC_PREFIX)/examples/
++ (test -d ../examples && install -m 644 ../examples/* $(DOC_PREFIX)/examples/) || true
+
+ # Targets to build python module
+ pymod: pacparser.o pacparser.h libjs.a
+ cd pymod && ARCHFLAGS="" $(PYTHON) setup.py build
++
++test-pymod: pymod
+ $(PYTHON) ../tests/runtests.py
+
+ install-pymod: pymod