summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-09-16 12:58:45 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-09-16 13:31:29 +0200
commit2ff6e6322d8dac4a0b001241c200e0862884f898 (patch)
treef6bb8646972891fc3c2a696405b0a320a6d63b3d /net-libs/rpcsvc-proto/rpcsvc-proto-1.2-r1.ebuild
parentkde-apps: Remove last-rited packages (diff)
downloadgentoo-2ff6e6322d8dac4a0b001241c200e0862884f898.tar.gz
gentoo-2ff6e6322d8dac4a0b001241c200e0862884f898.tar.bz2
gentoo-2ff6e6322d8dac4a0b001241c200e0862884f898.zip
net-libs/rpcsvc-proto: Fix some file collisions
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-libs/rpcsvc-proto/rpcsvc-proto-1.2-r1.ebuild')
-rw-r--r--net-libs/rpcsvc-proto/rpcsvc-proto-1.2-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-libs/rpcsvc-proto/rpcsvc-proto-1.2-r1.ebuild b/net-libs/rpcsvc-proto/rpcsvc-proto-1.2-r1.ebuild
new file mode 100644
index 000000000000..fa06a5e856c3
--- /dev/null
+++ b/net-libs/rpcsvc-proto/rpcsvc-proto-1.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="rpcsvc protocol definitions from glibc"
+HOMEPAGE="https://github.com/thkukuk/rpcsvc-proto"
+SRC_URI="https://github.com/thkukuk/${PN}/archive/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1+ BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!<sys-libs/glibc-2.26"
+
+S=${WORKDIR}/${PN}-${P}
+
+src_prepare(){
+ default
+ eautoreconf
+}
+
+src_install(){
+ default
+
+ # provided by sys-fs/quota[rpc]
+ rm "${ED}"/usr/include/rpcsvc/rquota.{x,h} || die
+}