summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-06-18 12:07:49 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-06-18 12:07:49 +0200
commit2ac7ea0da9012d1858789d0a45565e283678e81c (patch)
tree42339975a779fac26f402f3ef4edb7b74785984b /net-libs/rpcsvc-proto/rpcsvc-proto-1.4.ebuild
parentdev-python/pocketlint: Bump to version 0.16 (diff)
downloadgentoo-2ac7ea0da9012d1858789d0a45565e283678e81c.tar.gz
gentoo-2ac7ea0da9012d1858789d0a45565e283678e81c.tar.bz2
gentoo-2ac7ea0da9012d1858789d0a45565e283678e81c.zip
net-libs/rpcsvc-proto: Bump to version 1.4
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-libs/rpcsvc-proto/rpcsvc-proto-1.4.ebuild')
-rw-r--r--net-libs/rpcsvc-proto/rpcsvc-proto-1.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-libs/rpcsvc-proto/rpcsvc-proto-1.4.ebuild b/net-libs/rpcsvc-proto/rpcsvc-proto-1.4.ebuild
new file mode 100644
index 000000000000..af9ee8387e54
--- /dev/null
+++ b/net-libs/rpcsvc-proto/rpcsvc-proto-1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="rpcsvc protocol definitions from glibc"
+HOMEPAGE="https://github.com/thkukuk/rpcsvc-proto"
+SRC_URI="https://github.com/thkukuk/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1+ BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!<sys-libs/glibc-2.26"
+
+src_prepare(){
+ default
+ eautoreconf
+}
+
+src_install(){
+ default
+
+ # provided by sys-fs/quota[rpc]
+ rm "${ED%/}"/usr/include/rpcsvc/rquota.{x,h} || die
+}