summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-10-29 00:11:24 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-10-29 00:11:51 +1100
commitc41e09e64b1ddde8c06b629e1ad4a0f2f0fdef34 (patch)
tree357787b6a610f48d11a6faa7ee9d4715a912a935 /net-libs/signon-oauth2
parentgames-simulation/pmars-sdl: compile with format-security. Bug #544358 (diff)
downloadgentoo-c41e09e64b1ddde8c06b629e1ad4a0f2f0fdef34.tar.gz
gentoo-c41e09e64b1ddde8c06b629e1ad4a0f2f0fdef34.tar.bz2
gentoo-c41e09e64b1ddde8c06b629e1ad4a0f2f0fdef34.zip
net-libs/signon-oauth2: avoid build failure when unused dependency is not installed
Gentoo-bug: 564316 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-libs/signon-oauth2')
-rw-r--r--net-libs/signon-oauth2/files/signon-oauth2-0.21-unused-dependency.patch16
-rw-r--r--net-libs/signon-oauth2/signon-oauth2-0.21.ebuild4
2 files changed, 19 insertions, 1 deletions
diff --git a/net-libs/signon-oauth2/files/signon-oauth2-0.21-unused-dependency.patch b/net-libs/signon-oauth2/files/signon-oauth2-0.21-unused-dependency.patch
new file mode 100644
index 000000000000..3e6656dd272c
--- /dev/null
+++ b/net-libs/signon-oauth2/files/signon-oauth2-0.21-unused-dependency.patch
@@ -0,0 +1,16 @@
+Qt5XmlPatterns is not actually used, but build will fail if it's missing.
+
+Gentoo-bug: 564316
+
+--- src/src.pro
++++ src/src.pro
+@@ -4,8 +4,7 @@
+ TARGET = oauth2plugin
+ DESTDIR = lib/signon
+ QT += core \
+- network \
+- xmlpatterns
++ network
+ QT -= gui
+ CONFIG += plugin \
+ build_all \
diff --git a/net-libs/signon-oauth2/signon-oauth2-0.21.ebuild b/net-libs/signon-oauth2/signon-oauth2-0.21.ebuild
index 2c5b49bc870f..2bbabd6efc1b 100644
--- a/net-libs/signon-oauth2/signon-oauth2-0.21.ebuild
+++ b/net-libs/signon-oauth2/signon-oauth2-0.21.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit qmake-utils
+inherit eutils qmake-utils
DESCRIPTION="OAuth2 plugin for Signon daemon"
HOMEPAGE="https://01.org/gsso/"
@@ -30,6 +30,8 @@ src_prepare() {
else
sed -i -e '/^INSTALLS.*/,+1d' tests/tests.pro || die "couldn't remove tests from install target"
fi
+
+ epatch "${FILESDIR}/${P}-unused-dependency.patch"
}
src_configure() {