summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-05-24 09:58:33 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-05-24 09:59:55 +0200
commitfc645c971084f45e9d56db21eeee476172a1ef21 (patch)
tree8a4ac4d0aeb2566e3bbfc2c28e8c860e59cd96f8 /net-libs/socket_wrapper/socket_wrapper-1.1.7.ebuild
parentnet-libs/gsoap: Removed old. (diff)
downloadgentoo-fc645c971084f45e9d56db21eeee476172a1ef21.tar.gz
gentoo-fc645c971084f45e9d56db21eeee476172a1ef21.tar.bz2
gentoo-fc645c971084f45e9d56db21eeee476172a1ef21.zip
net-libs/socket_wrapper: Bump to version 1.1.7
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs/socket_wrapper/socket_wrapper-1.1.7.ebuild')
-rw-r--r--net-libs/socket_wrapper/socket_wrapper-1.1.7.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-libs/socket_wrapper/socket_wrapper-1.1.7.ebuild b/net-libs/socket_wrapper/socket_wrapper-1.1.7.ebuild
new file mode 100644
index 000000000000..fa15b39c96c1
--- /dev/null
+++ b/net-libs/socket_wrapper/socket_wrapper-1.1.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="A library passing all socket communications through unix sockets"
+HOMEPAGE="https://cwrap.org/socket_wrapper.html"
+SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+# Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
+# Because of this we cannot use cmake-multilib_src_configure() here.
+multilib_src_configure() {
+ local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
+ cmake-utils_src_configure
+}