summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-10-17 16:22:16 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-10-17 16:25:39 +0200
commit5f1170bc2dd2ee87cd06d1a07b9668be88a356ce (patch)
tree60000de524fe0188c3a4fc57f7f2d43c0d4a39dd /net-libs/socket_wrapper/socket_wrapper-1.1.8.ebuild
parentnet-analyzer/prometheus: Version bump to 2.0.0_rc1 (diff)
downloadgentoo-5f1170bc2dd2ee87cd06d1a07b9668be88a356ce.tar.gz
gentoo-5f1170bc2dd2ee87cd06d1a07b9668be88a356ce.tar.bz2
gentoo-5f1170bc2dd2ee87cd06d1a07b9668be88a356ce.zip
net-libs/socket_wrapper: Bump to version 1.1.8
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'net-libs/socket_wrapper/socket_wrapper-1.1.8.ebuild')
-rw-r--r--net-libs/socket_wrapper/socket_wrapper-1.1.8.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-libs/socket_wrapper/socket_wrapper-1.1.8.ebuild b/net-libs/socket_wrapper/socket_wrapper-1.1.8.ebuild
new file mode 100644
index 000000000000..4cbcd2bedf10
--- /dev/null
+++ b/net-libs/socket_wrapper/socket_wrapper-1.1.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="A library passing all socket communications through unix sockets"
+HOMEPAGE="https://cwrap.org/socket_wrapper.html"
+SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+# Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
+# Because of this we cannot use cmake-multilib_src_configure() here.
+multilib_src_configure() {
+ local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
+ cmake-utils_src_configure
+}