summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-04 00:12:37 +0100
committerSam James <sam@gentoo.org>2022-08-04 00:26:10 +0100
commitac3dc0e0e3695af6d5b31e83478717669ceff559 (patch)
treef2383107dbbec3cf37cae969c2fbd2d1c3658571 /net-libs/socket_wrapper
parentnet-libs/nodejs: add 18.7.0 (diff)
downloadgentoo-ac3dc0e0e3695af6d5b31e83478717669ceff559.tar.gz
gentoo-ac3dc0e0e3695af6d5b31e83478717669ceff559.tar.bz2
gentoo-ac3dc0e0e3695af6d5b31e83478717669ceff559.zip
net-libs/socket_wrapper: add 1.3.4
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/socket_wrapper')
-rw-r--r--net-libs/socket_wrapper/Manifest1
-rw-r--r--net-libs/socket_wrapper/socket_wrapper-1.3.4.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/net-libs/socket_wrapper/Manifest b/net-libs/socket_wrapper/Manifest
index db0b6d157fdc..05ac2accba78 100644
--- a/net-libs/socket_wrapper/Manifest
+++ b/net-libs/socket_wrapper/Manifest
@@ -1 +1,2 @@
DIST socket_wrapper-1.3.2.tar.gz 86255 BLAKE2B 33f526a8871cfb1a889a84660ea8e82b6e591646924e16d2c452bb001e0eb4c1457b8151208bbec55c13c40fd124c160fc85d0df227519f62a2683e4ea1acb85 SHA512 f4d3a7026f1777a4c3b5481a0f6e6057b6372e9b64f44523ec1ebf0a34159d7154493dce6ee3c95fbea15607c6ada1382f2475d5d553133a061c80719c135b9d
+DIST socket_wrapper-1.3.4.tar.gz 81997 BLAKE2B 5d290ef59c16fbdde362749196cc91c3f050518f82cb14fbafa3e00d5fb51a6b085b94b08413ca601731440d8eadb5dfbe8d011567fd67b1240b0cc380504813 SHA512 6e6a940e26d0f4dc4f1c0f84643d5a124bb2cccd1713481e9c42ea7986884928d736b1ef8da8a2aef3d3803938b6e1ebd30bdbe9784fda95a9a59cdbd1d19f61
diff --git a/net-libs/socket_wrapper/socket_wrapper-1.3.4.ebuild b/net-libs/socket_wrapper/socket_wrapper-1.3.4.ebuild
new file mode 100644
index 000000000000..52c36e4a8cc9
--- /dev/null
+++ b/net-libs/socket_wrapper/socket_wrapper-1.3.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="A library passing all socket communications through unix sockets"
+HOMEPAGE="https://cwrap.org/socket_wrapper.html"
+SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( >=dev-util/cmocka-1.1.0 )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUNIT_TESTING=$(usex test ON OFF)
+ )
+ cmake-multilib_src_configure
+}