summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-08-28 14:03:58 +0200
committerLars Wendler <polynomial-c@gentoo.org>2015-08-28 14:04:25 +0200
commitb020dff3f2d0f1d14bcf9b1229292ffbc134a284 (patch)
tree749f2d12f578fb7dd3d7487f6d54391abb104a3d /net-libs/socket_wrapper
parentsys-libs/nss_wrapper: Use cmake-multilib eclass. (diff)
downloadgentoo-b020dff3f2d0f1d14bcf9b1229292ffbc134a284.tar.gz
gentoo-b020dff3f2d0f1d14bcf9b1229292ffbc134a284.tar.bz2
gentoo-b020dff3f2d0f1d14bcf9b1229292ffbc134a284.zip
net-libs/socket_wrapper: Use cmake-multilib eclass.
Package-Manager: portage-2.2.20.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs/socket_wrapper')
-rw-r--r--net-libs/socket_wrapper/socket_wrapper-1.1.3.ebuild14
-rw-r--r--net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild14
2 files changed, 2 insertions, 26 deletions
diff --git a/net-libs/socket_wrapper/socket_wrapper-1.1.3.ebuild b/net-libs/socket_wrapper/socket_wrapper-1.1.3.ebuild
index 9f2fd922828b..640369fbb2eb 100644
--- a/net-libs/socket_wrapper/socket_wrapper-1.1.3.ebuild
+++ b/net-libs/socket_wrapper/socket_wrapper-1.1.3.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit cmake-utils multilib-minimal
+inherit cmake-multilib
DESCRIPTION="A library passing all socket communications through unix sockets"
HOMEPAGE="https://cwrap.org/socket_wrapper.html"
@@ -16,15 +16,3 @@ IUSE="test"
DEPEND=""
RDEPEND="${DEPEND}"
-
-multilib_src_configure() {
- cmake-utils_src_configure
-}
-
-multilib_src_compile() {
- cmake-utils_src_compile
-}
-
-multilib_src_install() {
- cmake-utils_src_install
-}
diff --git a/net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild b/net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild
index c1a6edfc20cb..51b698f90753 100644
--- a/net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild
+++ b/net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit cmake-utils multilib-minimal
+inherit cmake-multilib
DESCRIPTION="A library passing all socket communications through unix sockets"
HOMEPAGE="https://cwrap.org/socket_wrapper.html"
@@ -16,15 +16,3 @@ IUSE="test"
DEPEND=""
RDEPEND="${DEPEND}"
-
-multilib_src_configure() {
- cmake-utils_src_configure
-}
-
-multilib_src_compile() {
- cmake-utils_src_compile
-}
-
-multilib_src_install() {
- cmake-utils_src_install
-}