summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/stem
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/stem')
-rw-r--r--net-libs/stem/Manifest3
-rw-r--r--net-libs/stem/metadata.xml15
-rw-r--r--net-libs/stem/stem-1.3.0.ebuild39
-rw-r--r--net-libs/stem/stem-1.4.0.ebuild38
-rw-r--r--net-libs/stem/stem-1.4.1.ebuild38
5 files changed, 133 insertions, 0 deletions
diff --git a/net-libs/stem/Manifest b/net-libs/stem/Manifest
new file mode 100644
index 000000000000..1767ea31330a
--- /dev/null
+++ b/net-libs/stem/Manifest
@@ -0,0 +1,3 @@
+DIST stem-1.3.0.tar.bz2 1481513 SHA256 770e370156e0e92a9862e4670ee3f4ac385742006e578608528ee16cbab9d416 SHA512 dea65d026a27985432b291614dc3c8da7a628fad945a755abb706177864edd387c8ea96cd8358af60825b342896d57ea1daa96365efd5156bf8885e7a7aa9714 WHIRLPOOL 1e3d9f800ed9670a347d41c565250a42e1a166e24c55dc3a0128cd3b2c5d9a8f0e926e73338a4cdd846997911c11db5e2fa98f2b7dd5a259da523951d8bf1626
+DIST stem-1.4.0.tar.bz2 1569644 SHA256 6c8af06a6fa9553ad4da3e397cffa42d7ddd9396a1425b2757f125e7699ef83c SHA512 0d93355659ff04d8846133845636c0596e06331b6646a62c597c2d6156be39705ed182d480dde3e49653c4b5341f663e4da83610110383d9d8c395ac1e473191 WHIRLPOOL 3eb30be403980a6a446fa0fe666fe628ef1f732e5a7da6ae3db323e4053c7df866142faad979a69cfeecb031077896e4883c58fdb6b3db84f7c5502141b4df7c
+DIST stem-1.4.1.tar.bz2 1570151 SHA256 f2c460df59d63f60e5046221994be655a361c31b81cda0120e594999587869e8 SHA512 40ed898efd55d749dad9e02ff00cc4770f588f9d0fd40995d3a0ed4d13ac3bd7cf1fba011a01729668be30ef9627bd6b140d4fbd76cedb5fa5793d9750aa48b7 WHIRLPOOL 2a52c1bc4a0acb18ebaf12654f0f4a8c167992f994336db1c16d6e3d49039007a5832fb0e80ac78ba82e789144bb374f7ce1105bba3e5edd14e99e83c2514ebf
diff --git a/net-libs/stem/metadata.xml b/net-libs/stem/metadata.xml
new file mode 100644
index 000000000000..479e90dafa8a
--- /dev/null
+++ b/net-libs/stem/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">stem</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-libs/stem/stem-1.3.0.ebuild b/net-libs/stem/stem-1.3.0.ebuild
new file mode 100644
index 000000000000..659782bc791f
--- /dev/null
+++ b/net-libs/stem/stem-1.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# Python3.3 fails to execute the test script
+PYTHON_COMPAT=(python2_7)
+
+inherit vcs-snapshot distutils-r1
+
+DESCRIPTION="Stem is a Python controller library for Tor"
+HOMEPAGE="https://stem.torproject.org"
+SRC_URI="mirror://pypi/s/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}]
+ net-misc/tor )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="net-misc/tor"
+
+DOCS=( docs/{_static,_templates,api,tutorials,{change_log,api,contents,download,faq,index,tutorials}.rst} )
+
+python_prepare_all() {
+ # Disable failing test
+ sed -i -e "/test_expand_path/a \
+ \ \ \ \ return" test/integ/util/system.py || die
+ sed -i -e "/test_get_connections_by_ss/,+1d"\
+ test/integ/util/connection.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${PYTHON} run_tests.py --all --target RUN_ALL || die
+}
diff --git a/net-libs/stem/stem-1.4.0.ebuild b/net-libs/stem/stem-1.4.0.ebuild
new file mode 100644
index 000000000000..c2722cc644cc
--- /dev/null
+++ b/net-libs/stem/stem-1.4.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+
+inherit vcs-snapshot distutils-r1
+
+DESCRIPTION="Stem is a Python controller library for Tor"
+HOMEPAGE="https://stem.torproject.org"
+SRC_URI="mirror://pypi/s/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}]
+ net-misc/tor )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="net-misc/tor"
+
+DOCS=( docs/{_static,_templates,api,tutorials,{change_log,api,contents,download,faq,index,tutorials}.rst} )
+
+python_prepare_all() {
+ # Disable failing test
+ sed -i -e "/test_expand_path/a \
+ \ \ \ \ return" test/integ/util/system.py || die
+ sed -i -e "/test_get_connections_by_ss/,+1d"\
+ test/integ/util/connection.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${PYTHON} run_tests.py --all --target RUN_ALL || die
+}
diff --git a/net-libs/stem/stem-1.4.1.ebuild b/net-libs/stem/stem-1.4.1.ebuild
new file mode 100644
index 000000000000..c2722cc644cc
--- /dev/null
+++ b/net-libs/stem/stem-1.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+
+inherit vcs-snapshot distutils-r1
+
+DESCRIPTION="Stem is a Python controller library for Tor"
+HOMEPAGE="https://stem.torproject.org"
+SRC_URI="mirror://pypi/s/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}]
+ net-misc/tor )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="net-misc/tor"
+
+DOCS=( docs/{_static,_templates,api,tutorials,{change_log,api,contents,download,faq,index,tutorials}.rst} )
+
+python_prepare_all() {
+ # Disable failing test
+ sed -i -e "/test_expand_path/a \
+ \ \ \ \ return" test/integ/util/system.py || die
+ sed -i -e "/test_get_connections_by_ss/,+1d"\
+ test/integ/util/connection.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${PYTHON} run_tests.py --all --target RUN_ALL || die
+}