summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-21 12:09:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-29 14:03:42 +0100
commitce86df7eb9cdd27b8da28b84541ed0894fac4b53 (patch)
tree3924362d6b5210d43d0502e02ac8f34b776b09c9 /net-libs/telepathy-qt
parentkde5.eclass: Switch to cmake.eclass (diff)
downloadgentoo-ce86df7eb9cdd27b8da28b84541ed0894fac4b53.tar.gz
gentoo-ce86df7eb9cdd27b8da28b84541ed0894fac4b53.tar.bz2
gentoo-ce86df7eb9cdd27b8da28b84541ed0894fac4b53.zip
*/*: Switch kde proj packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/telepathy-qt')
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild b/net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild
index 1f505982cf39..54ad156b963e 100644
--- a/net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild
+++ b/net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{5,6,7} )
-inherit python-any-r1 cmake-utils virtualx
+inherit python-any-r1 cmake virtualx
DESCRIPTION="Qt bindings for the Telepathy D-Bus protocol"
HOMEPAGE="https://telepathy.freedesktop.org/"
@@ -61,7 +61,7 @@ src_configure() {
-DENABLE_TESTS=$(usex test)
-DENABLE_EXAMPLES=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
@@ -70,6 +70,6 @@ src_test() {
-E "(BaseConnectionManager|BaseProtocol)"
)
pushd "${BUILD_DIR}" > /dev/null || die
- virtx cmake-utils_src_test
+ virtx cmake_src_test
popd > /dev/null || die
}