summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-02-23 16:04:18 +0100
committerJeroen Roovers <jer@gentoo.org>2019-02-23 16:05:04 +0100
commit505720c1a7f14313facab4803d3527916997691f (patch)
tree09926d9e96ad7ea319858ba4ba458f1383ac9ab3 /net-libs/wandio/wandio-4.1.0.ebuild
parentx11-drivers/nvidia-drivers: Versions 390.116 410.104 418.43 (diff)
downloadgentoo-505720c1a7f14313facab4803d3527916997691f.tar.gz
gentoo-505720c1a7f14313facab4803d3527916997691f.tar.bz2
gentoo-505720c1a7f14313facab4803d3527916997691f.zip
net-libs/wandio: Version 4.1.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-libs/wandio/wandio-4.1.0.ebuild')
-rw-r--r--net-libs/wandio/wandio-4.1.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-libs/wandio/wandio-4.1.0.ebuild b/net-libs/wandio/wandio-4.1.0.ebuild
new file mode 100644
index 000000000000..3a063f9e560e
--- /dev/null
+++ b/net-libs/wandio/wandio-4.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Library for transparent file I/O with compression"
+HOMEPAGE="https://research.wand.net.nz/software/libwandio.php"
+SRC_URI="https://research.wand.net.nz/software/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/3.1.0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 http lzma lzo static-libs zlib"
+
+RDEPEND="
+ !<net-libs/libtrace-4
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo )
+ http? ( net-misc/curl )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with bzip2) \
+ $(use_with http) \
+ $(use_with lzma) \
+ $(use_with lzo) \
+ $(use_with zlib)
+}