summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2023-02-15 15:58:03 +0100
committerGuilherme Amadio <amadio@gentoo.org>2023-02-15 15:58:03 +0100
commit49b71c6963359de1c3d2cc2bb3b929011239cf4d (patch)
tree54d54266f786533911fe9401edd30839ed4f469a /net-libs/xrootd-ceph
parentnet-libs/xrootd-ceph: add remote-id to metadata.xml (diff)
downloadgentoo-49b71c6963359de1c3d2cc2bb3b929011239cf4d.tar.gz
gentoo-49b71c6963359de1c3d2cc2bb3b929011239cf4d.tar.bz2
gentoo-49b71c6963359de1c3d2cc2bb3b929011239cf4d.zip
net-libs/xrootd-ceph: add 5.5.2
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'net-libs/xrootd-ceph')
-rw-r--r--net-libs/xrootd-ceph/Manifest1
-rw-r--r--net-libs/xrootd-ceph/xrootd-ceph-5.5.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-libs/xrootd-ceph/Manifest b/net-libs/xrootd-ceph/Manifest
index 5f78eef2dbf7..701846da04d5 100644
--- a/net-libs/xrootd-ceph/Manifest
+++ b/net-libs/xrootd-ceph/Manifest
@@ -1 +1,2 @@
DIST xrootd-ceph-5.4.3.tar.gz 82057 BLAKE2B 3ca2a812e6a55d696c1336b28114e9d4ec46c18d764ab8966533e150bb7e3a040c58a957c73adfd4f79038b82ebafcc3b09eae2d7b06aba41e36ce94c36ac3fe SHA512 b1065cf55d3918eef5083ebd1737139a761a28e4cc41cd2b796e2a0157d7a86850e643cecd89aeef89419485397676ac7040df5a5e2e9f7405d26320dbe1c9e3
+DIST xrootd-ceph-5.5.2.tar.gz 82023 BLAKE2B 50976230f0832b7065cf73c2eaf57e4455788ce3d10b471183ce6735befd88791952702cc25dcc53a54b6458f75a9c816cc420e610e95485c0fa9c9027ae47f5 SHA512 cfa425d84ba065b92868f493f3dd72597bcfddbcc4a5d91cd75b440b4adce2a8cebfe448bd9747a07717819862bb231829d6ffbffeb6cc80e3491e8bb36c274a
diff --git a/net-libs/xrootd-ceph/xrootd-ceph-5.5.2.ebuild b/net-libs/xrootd-ceph/xrootd-ceph-5.5.2.ebuild
new file mode 100644
index 000000000000..ef04b6db3238
--- /dev/null
+++ b/net-libs/xrootd-ceph/xrootd-ceph-5.5.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="xrootd OSS plug-in for interfacing with Ceph storage platform"
+HOMEPAGE="https://xrootd.slac.stanford.edu/"
+SRC_URI="https://github.com/xrootd/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="~net-libs/xrootd-${PV}
+ sys-cluster/ceph"
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-util/cppunit )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.4.0_no-werror.patch
+)
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrdCeph.*-$(ver_cut 1)\.so
+ /usr/lib.*/libXrdCephTests\.so"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}