summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-05-14 12:56:36 +0200
committerMarek Szuba <marecki@gentoo.org>2020-05-14 19:04:42 +0200
commit9d4e659d447d875308c95555a82218912be29148 (patch)
tree53b47ef5b1e4ba4411aa4b8471eee0f6d1b6da85 /net-libs/xrootd
parentnet-im/telegram-desktop: bump 2.1.5 => 2.1.6 (diff)
downloadgentoo-9d4e659d447d875308c95555a82218912be29148.tar.gz
gentoo-9d4e659d447d875308c95555a82218912be29148.tar.bz2
gentoo-9d4e659d447d875308c95555a82218912be29148.zip
net-libs/xrootd: bump to 4.12.1
Bugfix release fixing a problem with Grid-related authentication present in 4.12.0. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/xrootd')
-rw-r--r--net-libs/xrootd/Manifest1
-rw-r--r--net-libs/xrootd/xrootd-4.12.1.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/net-libs/xrootd/Manifest b/net-libs/xrootd/Manifest
index 45d3d07ef45e..61aee4cf44d9 100644
--- a/net-libs/xrootd/Manifest
+++ b/net-libs/xrootd/Manifest
@@ -1,3 +1,4 @@
DIST xrootd-4.11.1.tar.gz 2549971 BLAKE2B e131769291d33d2198c4afdedd0d9f9a0eac9459654277763554d2dfba211b7123f3d0dfc90fe365c7f4da2590d9bec6daf994ee7ae241897aa10b4500362c3c SHA512 7853de40d40f28177f70a18f17ee99f83c8b6c6ddf0b5e7ef64df83c5457bad11e6249c75f985c207c3292fab73a2181730ce9c8bf11979535a566c5364de8a1
DIST xrootd-4.12.0.tar.gz 2564041 BLAKE2B 6ea9c379aa482c81279168baa3e1381e880d34014fb3516c96961da64d54faf649295f024313ece445df9a62b6b5c818b7aa8a987025d3cd969188de072648c9 SHA512 5338c4fb5461918473dd4f41f4d29fae09a8fc6a9e2d8f00bb74d929dc5396fef73643462d1a4f1ba71ffe5cf92a1695a167ca3a766c674a9377dcf99aaa1778
+DIST xrootd-4.12.1.tar.gz 2564202 BLAKE2B df6334884d12ea68d98f5e8d1c83bb44d9a7d9232f1350323beff8de3815fd24711a90b5180824c9a9fd3f9e4f45ad3448bb32cde57efd646343bf2fd202237e SHA512 8d5c7029ccad8cb898ff41671e6f360154549df926b1fb5e7747503bed477f7bf1daec7addbc5a832b76f0f5c40ef8fdcda708907389fa790c3b87a944af4d93
DIST xrootd-4.8.3.tar.gz 2390520 BLAKE2B 1b97225c41f6a3a751f55a4d357f53fac2e4cc24f2456962a6d6282b78faaeb844db5d69bff34437acd2c015dbff4a2a5047d6295770abd200d3e5bedd89d4fe SHA512 6f605131be18f35115bf7cf5d829dfd5a36e004ac69aa77dd0cb34ab70f2b89ff07e7b3e3259fe672d81b6241596c78a537de02e5abad4537dc92ae745ae8911
diff --git a/net-libs/xrootd/xrootd-4.12.1.ebuild b/net-libs/xrootd/xrootd-4.12.1.ebuild
new file mode 100644
index 000000000000..6acdc5a472ee
--- /dev/null
+++ b/net-libs/xrootd/xrootd-4.12.1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="Extended ROOT remote file server"
+HOMEPAGE="http://xrootd.org/"
+SRC_URI="http://xrootd.org/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples fuse http kerberos python readline ssl test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="acct-group/xrootd
+ acct-user/xrootd
+ sys-libs/zlib
+ fuse? ( sys-fs/fuse:= )
+ kerberos? ( virtual/krb5 )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:0= )
+ ssl? ( dev-libs/openssl:0= )
+"
+DEPEND="${CDEPEND}"
+BDEPEND="
+ doc? (
+ app-doc/doxygen[dot]
+ python? ( dev-python/sphinx )
+ )
+ test? ( dev-util/cppunit )
+"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+"
+REQUIRED_USE="
+ http? ( kerberos ssl )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+PATCHES=( "${FILESDIR}"/xrootd-4.8.3-crc32.patch )
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrd.*-$(ver_cut 1).so"
+
+pkg_setup() {
+ use python && python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CRYPTO=$(usex ssl)
+ -DENABLE_FUSE=$(usex fuse)
+ -DENABLE_HTTP=$(usex http)
+ -DENABLE_KRB5=$(usex kerberos)
+ -DENABLE_PYTHON=$(usex python)
+ -DENABLE_READLINE=$(usex readline)
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ doxygen Doxyfile || die
+ if use python; then
+ emake -C bindings/python/docs html
+ fi
+ fi
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doxydoc/html/. )
+ dodoc docs/ReleaseNotes.txt
+ cmake-utils_src_install
+ find "${D}" \( -iname '*.md5' -o -iname '*.map' \) -delete || die
+
+ # base configs
+ insinto /etc/xrootd
+ doins packaging/common/*.cfg
+
+ fowners root:xrootd /etc/xrootd
+ keepdir /var/log/xrootd
+ fowners xrootd:xrootd /var/log/xrootd
+
+ local i
+ for i in cmsd frm_purged frm_xfrd xrootd; do
+ newinitd "${FILESDIR}"/${i}.initd ${i}
+ done
+ # all daemons MUST use single master config file
+ newconfd "${FILESDIR}"/xrootd.confd xrootd
+
+ if use python; then
+ python_optimize "${D}/$(python_get_sitedir)"
+
+ if use doc; then
+ docinto python
+ docompress -x "/usr/share/doc/${PF}/python/html"
+ dodoc -r bindings/python/docs/build/html
+ fi
+ if use examples; then
+ docinto python
+ dodoc -r bindings/python/examples
+ fi
+ fi
+}