summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /net-libs/zeromq
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-libs/zeromq')
-rw-r--r--net-libs/zeromq/zeromq-2.2.0.ebuild3
-rw-r--r--net-libs/zeromq/zeromq-3.2.5.ebuild3
-rw-r--r--net-libs/zeromq/zeromq-4.3.2.ebuild1
3 files changed, 5 insertions, 2 deletions
diff --git a/net-libs/zeromq/zeromq-2.2.0.ebuild b/net-libs/zeromq/zeromq-2.2.0.ebuild
index 3aa9e3dd9622..a4cbd5d813aa 100644
--- a/net-libs/zeromq/zeromq-2.2.0.ebuild
+++ b/net-libs/zeromq/zeromq-2.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# NOTES:
@@ -16,6 +16,7 @@ LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="amd64 hppa ppc ppc64 x86 ~amd64-linux ~x86-linux"
IUSE="pgm test static-libs"
+RESTRICT="!test? ( test )"
RDEPEND="!net-libs/cppzmq"
DEPEND="pgm? (
diff --git a/net-libs/zeromq/zeromq-3.2.5.ebuild b/net-libs/zeromq/zeromq-3.2.5.ebuild
index 4f3efab45985..2d97ae7df61c 100644
--- a/net-libs/zeromq/zeromq-3.2.5.ebuild
+++ b/net-libs/zeromq/zeromq-3.2.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,6 +13,7 @@ LICENSE="LGPL-3"
SLOT="0/3"
KEYWORDS="amd64 arm hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="pgm test static-libs elibc_glibc"
+RESTRICT="!test? ( test )"
DEPEND="
|| ( sys-devel/gcc sys-devel/gcc-apple )
diff --git a/net-libs/zeromq/zeromq-4.3.2.ebuild b/net-libs/zeromq/zeromq-4.3.2.ebuild
index d3ca50a8bf78..8535b875a1d0 100644
--- a/net-libs/zeromq/zeromq-4.3.2.ebuild
+++ b/net-libs/zeromq/zeromq-4.3.2.ebuild
@@ -13,6 +13,7 @@ LICENSE="LGPL-3"
SLOT="0/5"
KEYWORDS="amd64 arm arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
IUSE="doc drafts pgm +sodium static-libs test unwind elibc_Darwin"
+RESTRICT="!test? ( test )"
RDEPEND="
!elibc_Darwin? ( unwind? ( sys-libs/libunwind ) )