summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2018-05-28 16:31:16 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-05-28 16:49:04 +0200
commit49f0f7a7e3cdf47ba3147d1abbbcf4b0d4c18cf1 (patch)
treeabd440b7e7febcfedb484a4c7a48e721bc866aba /net-libs/zeromq
parentmedia-fonts/oxygen-fonts: Fix self block (diff)
downloadgentoo-49f0f7a7e3cdf47ba3147d1abbbcf4b0d4c18cf1.tar.gz
gentoo-49f0f7a7e3cdf47ba3147d1abbbcf4b0d4c18cf1.tar.bz2
gentoo-49f0f7a7e3cdf47ba3147d1abbbcf4b0d4c18cf1.zip
net-libs/zeromq: Introduce drafts use flag
Closes: https://github.com/gentoo/gentoo/pull/8630 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-libs/zeromq')
-rw-r--r--net-libs/zeromq/metadata.xml4
-rw-r--r--net-libs/zeromq/zeromq-4.2.2-r2.ebuild3
-rw-r--r--net-libs/zeromq/zeromq-4.2.3.ebuild5
-rw-r--r--net-libs/zeromq/zeromq-4.2.5.ebuild3
4 files changed, 11 insertions, 4 deletions
diff --git a/net-libs/zeromq/metadata.xml b/net-libs/zeromq/metadata.xml
index 981328e740da..8d747a412580 100644
--- a/net-libs/zeromq/metadata.xml
+++ b/net-libs/zeromq/metadata.xml
@@ -28,6 +28,10 @@
<subslots>Reflect ABI of libzmq.so.</subslots>
</slots>
<use>
+ <flag name="drafts">
+ Build draft API, which may change at any time without any notice, and
+ is therefore not recommended for normal use.
+ </flag>
<flag name="pgm">
Build PGM (Pragmatic General Multicast)extention, a protocol for reliable
multicast transport of data over IP networks.
diff --git a/net-libs/zeromq/zeromq-4.2.2-r2.ebuild b/net-libs/zeromq/zeromq-4.2.2-r2.ebuild
index 9afe36287c87..8c2ee822f163 100644
--- a/net-libs/zeromq/zeromq-4.2.2-r2.ebuild
+++ b/net-libs/zeromq/zeromq-4.2.2-r2.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/zeromq/libzmq/releases/download/v${PV}/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0/5"
KEYWORDS="amd64 arm arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc pgm +sodium static-libs test unwind elibc_Darwin"
+IUSE="doc drafts pgm +sodium static-libs test unwind elibc_Darwin"
RDEPEND="
!elibc_Darwin? ( unwind? ( sys-libs/libunwind ) )
@@ -40,6 +40,7 @@ src_prepare() {
src_configure() {
local myeconfargs=(
--enable-shared
+ $(use_enable drafts)
$(use_enable static-libs static)
$(use_enable unwind libunwind)
$(use_with sodium libsodium)
diff --git a/net-libs/zeromq/zeromq-4.2.3.ebuild b/net-libs/zeromq/zeromq-4.2.3.ebuild
index cdef847f86e4..da4a8da09188 100644
--- a/net-libs/zeromq/zeromq-4.2.3.ebuild
+++ b/net-libs/zeromq/zeromq-4.2.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/zeromq/libzmq/releases/download/v${PV}/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0/5"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc pgm +sodium static-libs test unwind elibc_Darwin"
+IUSE="doc drafts pgm +sodium static-libs test unwind elibc_Darwin"
RDEPEND="
!elibc_Darwin? ( unwind? ( sys-libs/libunwind ) )
@@ -39,6 +39,7 @@ src_prepare() {
src_configure() {
local myeconfargs=(
--enable-shared
+ $(use_enable drafts)
$(use_enable static-libs static)
$(use_enable unwind libunwind)
$(use_with sodium libsodium)
diff --git a/net-libs/zeromq/zeromq-4.2.5.ebuild b/net-libs/zeromq/zeromq-4.2.5.ebuild
index 5d8ebac8b7fe..da4a8da09188 100644
--- a/net-libs/zeromq/zeromq-4.2.5.ebuild
+++ b/net-libs/zeromq/zeromq-4.2.5.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/zeromq/libzmq/releases/download/v${PV}/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0/5"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc pgm +sodium static-libs test unwind elibc_Darwin"
+IUSE="doc drafts pgm +sodium static-libs test unwind elibc_Darwin"
RDEPEND="
!elibc_Darwin? ( unwind? ( sys-libs/libunwind ) )
@@ -39,6 +39,7 @@ src_prepare() {
src_configure() {
local myeconfargs=(
--enable-shared
+ $(use_enable drafts)
$(use_enable static-libs static)
$(use_enable unwind libunwind)
$(use_with sodium libsodium)