summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2019-04-13 13:29:23 +1000
committerMichael Palimaka <kensington@gentoo.org>2019-04-13 13:29:33 +1000
commit0eb2820e924186da0d6ff61c9a42aac4cc2223ca (patch)
tree39ff04811631e6820e03c6886bd7963bba0e5246 /net-libs
parentsys-apps/hwids: arm64 stable (bug #680018) (diff)
downloadgentoo-0eb2820e924186da0d6ff61c9a42aac4cc2223ca.tar.gz
gentoo-0eb2820e924186da0d6ff61c9a42aac4cc2223ca.tar.bz2
gentoo-0eb2820e924186da0d6ff61c9a42aac4cc2223ca.zip
net-libs/libssh: disable tests that take too long and timeout
Closes: https://bugs.gentoo.org/677006 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libssh/libssh-0.8.7.ebuild8
-rw-r--r--net-libs/libssh/libssh-9999.ebuild10
2 files changed, 17 insertions, 1 deletions
diff --git a/net-libs/libssh/libssh-0.8.7.ebuild b/net-libs/libssh/libssh-0.8.7.ebuild
index 4a55b7bbf1e7..a2353f90c6bd 100644
--- a/net-libs/libssh/libssh-0.8.7.ebuild
+++ b/net-libs/libssh/libssh-0.8.7.ebuild
@@ -59,6 +59,14 @@ src_prepare() {
sed -i \
-e '/torture_keyfiles/d' \
tests/unittests/CMakeLists.txt || die
+
+ # disable tests that take too long (bug #677006)
+ if use sparc; then
+ sed -i \
+ -e '/torture_threads_pki_rsa/d' \
+ -e '/torture_pki_dsa/d' \
+ tests/unittests/CMakeLists.txt || die
+ fi
}
multilib_src_configure() {
diff --git a/net-libs/libssh/libssh-9999.ebuild b/net-libs/libssh/libssh-9999.ebuild
index 5137fc6f8d22..d88693448ce5 100644
--- a/net-libs/libssh/libssh-9999.ebuild
+++ b/net-libs/libssh/libssh-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -57,6 +57,14 @@ src_prepare() {
sed -i \
-e '/torture_keyfiles/d' \
tests/unittests/CMakeLists.txt || die
+
+ # disable tests that take too long (bug #677006)
+ if use sparc; then
+ sed -i \
+ -e '/torture_threads_pki_rsa/d' \
+ -e '/torture_pki_dsa/d' \
+ tests/unittests/CMakeLists.txt || die
+ fi
}
multilib_src_configure() {