summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-01-22 00:21:21 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-01-22 00:22:41 +0300
commit102cd3bc3765fe2ab787ffaa6d4a8f6a60e2d4d1 (patch)
treebaae018c9a624dc2adeac041072b5f0616138917 /net-libs
parentx11-wm/awesome: cleanup old (diff)
downloadgentoo-102cd3bc3765fe2ab787ffaa6d4a8f6a60e2d4d1.tar.gz
gentoo-102cd3bc3765fe2ab787ffaa6d4a8f6a60e2d4d1.tar.bz2
gentoo-102cd3bc3765fe2ab787ffaa6d4a8f6a60e2d4d1.zip
net-libs/libtorrent-rasterbar: Version bump (v1.2.11)
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtorrent-rasterbar/Manifest1
-rw-r--r--net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.11.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/net-libs/libtorrent-rasterbar/Manifest b/net-libs/libtorrent-rasterbar/Manifest
index d1187e78d119..2d68ffde2eab 100644
--- a/net-libs/libtorrent-rasterbar/Manifest
+++ b/net-libs/libtorrent-rasterbar/Manifest
@@ -1,3 +1,4 @@
DIST libtorrent-1.2.10.tar.gz 3586008 BLAKE2B 71971124930462feb5f5083fed38ccadcfd1a2aed0d000a06cd7e0898b40a1451722cd79fdf0b1da3477047b26c7f7e3c1f74086a141770a7d143c916e96b6bb SHA512 e6de939fb6527783695e0b6623ddbe27f85842a36c0899b93ea0284cb3c6f3d14b8c39e29316adb3bf9acac7804f38385cc06854a32df28e7f4f6839af9f382d
+DIST libtorrent-1.2.11.tar.gz 3591610 BLAKE2B fab5d780dc5e1a855b60326cefdca6bcfb7459d4d37429e1c475434ca6ca2f465ffb6188ff519f49f2612941fe4806152511400a1c6fe121ade3ed35c6f40a79 SHA512 d502286f67bf462f14169daafe12b94ca723598530c85360c3a4b3c73535202b63632036248fdecc942cb559e66e6a5cb5afa830dc78bbff72a6c9a330710b62
DIST libtorrent-1.2.9.tar.gz 3584800 BLAKE2B 5160056e227a54992ca4e490ffe0088d080aa9bade7a76f55eac26a644bab720c39a70b90d94f465ec711893249a084d9f77fa496be770585094b9b3ea4a1cdd SHA512 c547d96470f6a89f22adc0f5579ffb98b877a46f0a163698c49f1de57f23af60a7b0d3c1ca482e3ed8d3e35124d14a1d16a53e455f4d69f347fcb33c6ded75a8
DIST libtorrent-rasterbar-1.2.6.tar.gz 3611015 BLAKE2B 39323c223927272a4eb9bb93ad70acd62165b9b3eb3f4f45cb76f99a23b1e131b526c8d8370fbd7cc30c7e776a5f9b7990c989ceaa3566272adc25df639fc5ba SHA512 9f03e28449b08e18a98a1f1bf0571f470c56fabd2becde5bde56ad566611c8519b0b387939f285a552d1f0382446633b67d00b6b5ff7083e4d1420a3ce9232fc
diff --git a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.11.ebuild b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.11.ebuild
new file mode 100644
index 000000000000..ae8f66e78a11
--- /dev/null
+++ b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.11.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_OPTIONAL=true
+DISTUTILS_IN_SOURCE_BUILD=true
+
+inherit autotools flag-o-matic distutils-r1
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="https://libtorrent.org https://github.com/arvidn/libtorrent"
+SRC_URI="https://github.com/arvidn/libtorrent/archive/v${PV}.tar.gz -> libtorrent-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/10"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug +dht doc examples libressl python +ssl static-libs test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/libtorrent-${PV}"
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ virtual/libiconv
+ examples? ( !net-p2p/mldonkey )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+"
+
+src_prepare() {
+ mkdir -p "${S}"/build-aux || die
+ touch "${S}"/build-aux/config.rpath || die
+ append-cxxflags -std=c++14
+ eautoreconf
+
+ default
+
+ # bug 578026
+ # prepend -L${S}/... to ensure bindings link against the lib we just built
+ sed -i -e "s|^|-L${S}/src/.libs |" bindings/python/link_flags.in || die
+
+ # prepend -I${S}/... to ensure bindings use the right headers
+ sed -i -e "s|^|-I${S}/src/include |" bindings/python/compile_flags.in || die
+
+ use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable debug export-all)
+ $(use_enable debug logging)
+ $(use_enable dht)
+ $(use_enable examples)
+ $(use_enable ssl encryption)
+ $(use_enable static-libs static)
+ $(use_enable test tests)
+ --with-boost
+ --with-libiconv
+ --enable-logging
+ )
+ econf "${myeconfargs[@]}"
+
+ if use python; then
+ python_configure() {
+ econf "${myeconfargs[@]}" \
+ --enable-python-binding \
+ --with-boost-python="boost_${EPYTHON/./}"
+ # git rid of c++11
+ sed s/-std=c++11//g < bindings/python/compile_cmd > bindings/python/compile_cmd.new || die
+ mv -f bindings/python/compile_cmd.new bindings/python/compile_cmd || die
+ }
+ distutils-r1_src_configure
+ fi
+}
+
+src_compile() {
+ default
+
+ python_compile() {
+ cd "${BUILD_DIR}/../bindings/python" || die
+ distutils-r1_python_compile
+ }
+ use python && distutils-r1_src_compile
+}
+
+src_install() {
+ use doc && HTML_DOCS+=( "${S}"/docs )
+
+ default
+
+ python_install() {
+ cd "${BUILD_DIR}/../bindings/python" || die
+ distutils-r1_python_install
+ }
+ use python && distutils-r1_src_install
+
+ find "${D}" -name '*.la' -delete || die
+}