summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-03-26 14:31:05 +0200
committerUlrich Müller <ulm@gentoo.org>2017-03-26 14:34:10 +0200
commit14d049f4480fd2a1b49bc9e60a00f3ae39e29424 (patch)
tree9b0721e4f54e8de7a56a425d7aa6e4501e5270e4 /net-libs
parentnet-mail/notmuch: Follow guidlines for completion files (diff)
downloadgentoo-14d049f4480fd2a1b49bc9e60a00f3ae39e29424.tar.gz
gentoo-14d049f4480fd2a1b49bc9e60a00f3ae39e29424.tar.bz2
gentoo-14d049f4480fd2a1b49bc9e60a00f3ae39e29424.zip
net-libs/adns: [QA] Don't access FILESDIR in pkg_postinst.
Bump to EAPI 6. Avoid dohtml. Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/adns/adns-1.4-r2.ebuild (renamed from net-libs/adns/adns-1.4-r1.ebuild)25
-rw-r--r--net-libs/adns/adns-1.4.ebuild5
-rw-r--r--net-libs/adns/files/adns-1.4-cnamechain.patch18
3 files changed, 24 insertions, 24 deletions
diff --git a/net-libs/adns/adns-1.4-r1.ebuild b/net-libs/adns/adns-1.4-r2.ebuild
index b6695fc41d5b..6e0e060ea030 100644
--- a/net-libs/adns/adns-1.4-r1.ebuild
+++ b/net-libs/adns/adns-1.4-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
-inherit eutils multilib toolchain-funcs
+inherit multilib toolchain-funcs
DESCRIPTION="Advanced, easy to use, asynchronous-capable DNS client library and utilities"
HOMEPAGE="http://www.chiark.greenend.org.uk/~ian/adns/"
@@ -12,32 +12,31 @@ SRC_URI="ftp://ftp.chiark.greenend.org.uk/users/ian/adns/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
src_prepare() {
- epatch "${FILESDIR}"/${P}-cnamechain.patch
+ eapply "${FILESDIR}"/${P}-cnamechain.patch
#remove bogus test wrt bug #295072
rm "${S}"/regress/case-cnametocname.sys
+ eapply_user
}
src_configure() {
- CC=$(tc-getCC) econf || die "econf failed"
+ CC=$(tc-getCC) econf
}
src_compile() {
- emake AR=$(tc-getAR) RANLIB=$(tc-getRANLIB) || die "emake failed"
+ emake AR=$(tc-getAR) RANLIB=$(tc-getRANLIB)
}
src_install () {
dodir /usr/{include,bin,$(get_libdir)}
- emake prefix="${D}"/usr libdir="${D}"/usr/$(get_libdir) install || die "emake install failed"
+ emake prefix="${ED}"/usr libdir="${ED}"/usr/$(get_libdir) install
dodoc README TODO changelog "${FILESDIR}"/README.security
- dohtml *.html
+ docinto html
+ dodoc README.html
+ MY_POSTINST_MSG=$(<"${FILESDIR}"/README.security)
}
pkg_postinst() {
- ewarn "$(<${FILESDIR}/README.security)"
+ ewarn "${MY_POSTINST_MSG}"
}
diff --git a/net-libs/adns/adns-1.4.ebuild b/net-libs/adns/adns-1.4.ebuild
index b91bea2796fc..92258217447e 100644
--- a/net-libs/adns/adns-1.4.ebuild
+++ b/net-libs/adns/adns-1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
inherit eutils multilib toolchain-funcs
@@ -25,8 +25,9 @@ src_install () {
emake prefix="${D}"/usr libdir="${D}"/usr/$(get_libdir) install || die "emake install failed"
dodoc README TODO changelog "${FILESDIR}"/README.security
dohtml *.html
+ MY_POSTINST_MSG=$(<"${FILESDIR}"/README.security)
}
pkg_postinst() {
- ewarn "$(<${FILESDIR}/README.security)"
+ ewarn "${MY_POSTINST_MSG}"
}
diff --git a/net-libs/adns/files/adns-1.4-cnamechain.patch b/net-libs/adns/files/adns-1.4-cnamechain.patch
index 4c87a1434660..9edf69461c01 100644
--- a/net-libs/adns/files/adns-1.4-cnamechain.patch
+++ b/net-libs/adns/files/adns-1.4-cnamechain.patch
@@ -68,14 +68,14 @@ Systems Architect | InfoInterActive Corp. | A Canadian AOL Company
Content-Type: text/plain; charset=us-ascii
Content-Disposition: attachment; filename="cname_chains.diff"
-Index: src/internal.h
+Index: adns-1.0/src/internal.h
===================================================================
RCS file: /iia/cvsroot/3rdParty/gnu/adns/adns-1.0/src/internal.h,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -p -r1.3 -r1.4
---- src/internal.h 2 Oct 2003 17:01:46 -0000 1.3
-+++ src/internal.h 2 Oct 2003 17:14:29 -0000 1.4
+--- adns-1.0/src/internal.h 2 Oct 2003 17:01:46 -0000 1.3
++++ adns-1.0/src/internal.h 2 Oct 2003 17:14:29 -0000 1.4
@@ -206,6 +206,9 @@ struct adns__query {
int cname_dglen, cname_begin;
/* If non-0, has been allocated using . */
@@ -86,14 +86,14 @@ diff -u -p -r1.3 -r1.4
vbuf search_vb;
int search_origlen, search_pos, search_doneabs;
/* Used by the searching algorithm. The query domain in textual form
-Index: src/query.c
+Index: adns-1.0/src/query.c
===================================================================
RCS file: /iia/cvsroot/3rdParty/gnu/adns/adns-1.0/src/query.c,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -p -r1.3 -r1.4
---- src/query.c 2 Oct 2003 17:01:47 -0000 1.3
-+++ src/query.c 2 Oct 2003 17:14:29 -0000 1.4
+--- adns-1.0/src/query.c 2 Oct 2003 17:01:47 -0000 1.3
++++ adns-1.0/src/query.c 2 Oct 2003 17:14:29 -0000 1.4
@@ -63,6 +63,8 @@ static adns_query query_alloc(adns_state
qu->cname_dgram= 0;
@@ -103,14 +103,14 @@ diff -u -p -r1.3 -r1.4
adns__vbuf_init(&qu->search_vb);
qu->search_origlen= qu->search_pos= qu->search_doneabs= 0;
-Index: src/reply.c
+Index: adns-1.0/src/reply.c
===================================================================
RCS file: /iia/cvsroot/3rdParty/gnu/adns/adns-1.0/src/reply.c,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -p -r1.3 -r1.4
---- src/reply.c 2 Oct 2003 17:01:47 -0000 1.3
-+++ src/reply.c 2 Oct 2003 17:14:30 -0000 1.4
+--- adns-1.0/src/reply.c 2 Oct 2003 17:01:47 -0000 1.3
++++ adns-1.0/src/reply.c 2 Oct 2003 17:14:30 -0000 1.4
@@ -191,12 +191,13 @@ void adns__procdgram(adns_state ads, con
if (qu->flags & adns_qf_cname_forbid) {
adns__query_fail(qu,adns_s_prohibitedcname);