summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2016-01-27 07:45:15 +0100
committerWolfram Schlich <wschlich@gentoo.org>2016-01-27 07:45:37 +0100
commit1cfce963ddf292815ded6cf1b9c8e452c4a012c5 (patch)
treec6f55ac8f9bf9460fdb23b28f0da89b1322365e3 /net-libs
parentdev-ruby/ruby-mp3info: add 0.8.8 (diff)
downloadgentoo-1cfce963ddf292815ded6cf1b9c8e452c4a012c5.tar.gz
gentoo-1cfce963ddf292815ded6cf1b9c8e452c4a012c5.tar.bz2
gentoo-1cfce963ddf292815ded6cf1b9c8e452c4a012c5.zip
net-libs/loudmouth: version bump (with temporarily different SRC_URI)
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/loudmouth/Manifest1
-rw-r--r--net-libs/loudmouth/loudmouth-1.5.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/net-libs/loudmouth/Manifest b/net-libs/loudmouth/Manifest
index bda372550a83..b1b37be011e1 100644
--- a/net-libs/loudmouth/Manifest
+++ b/net-libs/loudmouth/Manifest
@@ -1,2 +1,3 @@
DIST loudmouth-1.4.3.tar.bz2 366818 SHA256 95a93f5d009b71ea8193d994aa11f311bc330a3efe1b7cd74dc48f11c7f929e3 SHA512 02d1de14a4d626a4c9100bd24c06d4b4203eabb0f95bab40ee18ea5e68ed81d47aa977625140157b2d9f7974ac748af857c2ee3a916f0db700e2a2d0934940ec WHIRLPOOL 4f9e3e8e4f2fd0a36996e84deebeb26c789d5334af11a3d6cc6c742b59508945a6279715f6fbb02bbbc04a0d9709e7aae4cc39803b2a60acfd47d76f0482f969
DIST loudmouth-1.5.1.tar.gz 115811 SHA256 9b0219233004da2f159175ef189363851b3df607e3777c422da1f5545daa17b3 SHA512 d90096a2d10819b620f366a4d6998b281692ef65e0c27f2f59031e3f7495f278ec73a8d18ff38a7234f179b4f7f6adafa532a820023fd615dcf18c2ecd0d8982 WHIRLPOOL 4c3649c9d87088d68b01f0284d1fcd3abedf31dda6c8d9527785b79802ce2c7ac2a9fe4e0d0fe7a09926e4e9f6b06661ab857f272a3db5186125b20a9ba979f0
+DIST loudmouth-1.5.2.tar.bz2 354286 SHA256 91aae2df16be6f4286506bc04feffb9eb0138cfe8ca93a3cd8c1322b458a29e9 SHA512 5c49e20e7b57768fd3dca2fe837769084287fcf3a99d26c1d25753e60eedf6bd39134ac19c4b8730530e90c0bb92f37dc01c78bddc169281693d84af50b96ae3 WHIRLPOOL b4b2040478c37be126b38bbc176f7175f9c49da1872c384aa29d02fe4c0375a1ff698de6859b75555d9fba58fb6c00293fb6c067a4357be77c0e723c25efbe9e
diff --git a/net-libs/loudmouth/loudmouth-1.5.2.ebuild b/net-libs/loudmouth/loudmouth-1.5.2.ebuild
new file mode 100644
index 000000000000..f37d59f59880
--- /dev/null
+++ b/net-libs/loudmouth/loudmouth-1.5.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Lightweight C Jabber library"
+HOMEPAGE="https://github.com/mcabber/loudmouth"
+#SRC_URI="https://github.com/mcabber/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://mcabber.com/files/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+
+IUSE="asyncns ssl openssl static-libs test"
+
+# Automagic libidn dependency
+RDEPEND="
+ >=dev-libs/glib-2.16:2
+ net-dns/libidn
+ ssl? (
+ !openssl? ( >=net-libs/gnutls-1.4.0 )
+ openssl? ( dev-libs/openssl:0 )
+ )
+ asyncns? ( >=net-libs/libasyncns-0.3 )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )
+ virtual/pkgconfig
+ >=dev-util/gtk-doc-am-1
+"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ if use ssl; then
+ if ! use openssl; then
+ myconf="${myconf} --with-ssl=gnutls"
+ else
+ myconf="${myconf} --with-ssl=openssl"
+ fi
+ else
+ myconf="${myconf} --with-ssl=no"
+ fi
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with asyncns) \
+ ${myconf}
+}