summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-08-18 21:26:59 +0200
committerLars Wendler <polynomial-c@gentoo.org>2015-08-18 21:28:33 +0200
commit1d5e72ddd91da28971f105b02384d249bfc6f675 (patch)
tree47b697f655ab543d21833461deee3758988db381 /net-libs
parentsys-fs/udev: sync live ebuild (diff)
downloadgentoo-1d5e72ddd91da28971f105b02384d249bfc6f675.tar.gz
gentoo-1d5e72ddd91da28971f105b02384d249bfc6f675.tar.bz2
gentoo-1d5e72ddd91da28971f105b02384d249bfc6f675.zip
net-libs/gsoap: Version bump.
Package-Manager: portage-2.2.20.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gsoap/Manifest1
-rw-r--r--net-libs/gsoap/gsoap-2.8.23.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/net-libs/gsoap/Manifest b/net-libs/gsoap/Manifest
index 09473c22e02a..ae7938191bc7 100644
--- a/net-libs/gsoap/Manifest
+++ b/net-libs/gsoap/Manifest
@@ -3,3 +3,4 @@ DIST gsoap_2.8.12.zip 19974348 SHA256 51eef118544fa846f4d2dea2eedf91c84c46a1abea
DIST gsoap_2.8.19.zip 20628629 SHA256 11571e4274bb678cd979fb6e80caa0f74d41e1b17848fdb5192497553bb2f8fe SHA512 890f46976322cc409081c3fe9731452244c0c1efba9061b2d2d42a9449c0290be7801bf88c90dbce4aedf1118e2f888e83891d8d6c3c40e2add304f68480fc5a WHIRLPOOL 8113c7c80fcd4d39f340a5950a050980a09194a62e50665b9a661efa5eaeb624cc5031412057f50a44dd465e32e7bda188121b92c480bb00ca34ccf5678e2d43
DIST gsoap_2.8.21.zip 20633048 SHA256 ddda90866288c7c3d50851b276bfa12e0ef2d4af6d280719aad94b1da0ea109a SHA512 c46f6b6c0ef6055df483408038d0bce822dcee42ff581e0a6350000402916a8ce227fd5b34685a09f95189086584a4aad3b2c5b4e86fea70bcfa50b726fd04f9 WHIRLPOOL 3e38a3f8263a4de01727c9562e4da6156946839dbeb8caad5d6ef665b195b8b1b692bcca8cb88b58e80c1c224190fa29cc0e6c2eee7117cd6b8b875619fe41c3
DIST gsoap_2.8.22.zip 20806602 SHA256 2fdf14e6e4dece9409db53a3c4676a0b25711279bc2a8d8949a46c2d9907308b SHA512 b7a1b44d21e98b90efc68efa5a61ac69a4a312a3ca87ac4379d6ea15d4d81393fc5921212363f99a8cb1f7a28a736f5869c49318e94110de3df36ce20fc11822 WHIRLPOOL 0e7de5379382702c076a74fea875b4dd9bd1aec54c847919c5831afa8a14e1663aa4d97fd1c8088a7b7aaa9b32485561b2b519802f3a4984cfa87f7a8167fd05
+DIST gsoap_2.8.23.zip 22482000 SHA256 e1c30743f1c2cf40b2760568127e14af1b2a00c3026b2e5f0750e8c33d94c061 SHA512 cc90aadfe09aa6406172c9ffa07696851ff594ca7c5b40819494badd8ce978d908d66de63a5831e7aec1bca18ee8b51ed02187057688a3b36eb0a21fe6e0f5a4 WHIRLPOOL e5cfc9c5758847d1fc94cbd38108b80c7548abc0316fe201b58604a3b22d30b9748c81d4aec13f53356593f3ddc2dcba14170a53d63795eab9229ec49d4bc585
diff --git a/net-libs/gsoap/gsoap-2.8.23.ebuild b/net-libs/gsoap/gsoap-2.8.23.ebuild
new file mode 100644
index 000000000000..8aeb97d05c81
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.23.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 gnutls +ssl"
+
+DEPEND="app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? ( dev-libs/openssl:= )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Fix Pre-ISO headers
+ epatch "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+ use ssl || myconf+=( --disable-ssl )
+ use gnutls && myconf+=( --enable-gnutls )
+ use ipv6 && myconf+=( --enable-ipv6 )
+ econf \
+ ${myconf[@]} \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.md
+
+ prune_libtool_files --all
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}