summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-10-21 11:29:20 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-10-21 12:07:54 +0200
commit2b148652b782cb20d28ac85afd1331d42c04c783 (patch)
treeb215edc7f1871b514e5149f1081ee92f44bf935a /net-libs
parentnet-libs/gnome-online-accounts: version bump 3.24.3 → 3.24.4 (diff)
downloadgentoo-2b148652b782cb20d28ac85afd1331d42c04c783.tar.gz
gentoo-2b148652b782cb20d28ac85afd1331d42c04c783.tar.bz2
gentoo-2b148652b782cb20d28ac85afd1331d42c04c783.zip
net-libs/rest: version bump 0.8.0 → 0.8.1
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/rest/Manifest1
-rw-r--r--net-libs/rest/rest-0.8.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-libs/rest/Manifest b/net-libs/rest/Manifest
index 26f1d0f79fc8..5607434dc7c2 100644
--- a/net-libs/rest/Manifest
+++ b/net-libs/rest/Manifest
@@ -1 +1,2 @@
DIST rest-0.8.0.tar.xz 334024 SHA256 e7b89b200c1417073aef739e8a27ff2ab578056c27796ec74f5886a5e0dff647 SHA512 dfcfed4196e613ed4415ea04eaa890e47d1d2e6899afdefff3dd7bfed5bcace58724158deb4c0cc7974f9a4493d00d5c0a27415160f2795df81c2210c14a823a WHIRLPOOL b4a2de0fac2fe5bd6280c5e06a18a2b3b2fe1ca3d6f6a38ae1a34c3a9d1a3d8efa8c19ffac15ed4f9ca2ef7a7febf225f8954f6446c3a7078a3e2c02ff08ee73
+DIST rest-0.8.1.tar.xz 333376 SHA256 0513aad38e5d3cedd4ae3c551634e3be1b9baaa79775e53b2dba9456f15b01c9 SHA512 824a341db3827e4360abe03e33735918c68913c70d797699ef74271080a1985872006ec70fd994dc8fa3fbfef417e6fe979883c11286512d0ce623b8368e40c3 WHIRLPOOL cab32832ed08c60bfd662a6b32d7b98b0300e60032c979dc9ac1152f0fcf39e63d1eb1a4b5d65bfae5fae9e3e5cc9e4ac94cc14eda86c0a0000aa00e9c52d872
diff --git a/net-libs/rest/rest-0.8.1.ebuild b/net-libs/rest/rest-0.8.1.ebuild
new file mode 100644
index 000000000000..da3e684eae12
--- /dev/null
+++ b/net-libs/rest/rest-0.8.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 multilib-minimal virtualx
+
+DESCRIPTION="Helper library for RESTful services"
+HOMEPAGE="https://wiki.gnome.org/Projects/Librest"
+
+LICENSE="LGPL-2.1"
+SLOT="0.7"
+IUSE="+introspection test"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Coverage testing should not be enabled
+RDEPEND="
+ app-misc/ca-certificates
+ >=dev-libs/glib-2.24:2[${MULTILIB_USEDEP}]
+ dev-libs/libxml2:2[${MULTILIB_USEDEP}]
+ net-libs/libsoup:2.4[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ test? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+"
+
+multilib_src_configure() {
+ # gnome support only adds dependency on obsolete libsoup-gnome
+ # https://bugzilla.gnome.org/show_bug.cgi?id=758166
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --disable-static \
+ --disable-gcov \
+ --without-gnome \
+ --with-ca-certificates="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
+ $(multilib_native_use_enable introspection)
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/reference/rest/html docs/reference/rest/html || die
+ fi
+}
+
+multilib_src_test() {
+ # Tests need dbus
+ virtx emake check
+}
+
+multilib_src_compile() {
+ gnome2_src_compile
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}