summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2016-11-04 03:41:27 +0100
committerThomas Deutschmann <whissi@gentoo.org>2016-11-04 03:41:52 +0100
commit30624abf0dab82565dfbade028c0c7d7aa56944d (patch)
treef18b6826ab7d84b0dd4eb9fc1714809b6d31beed /net-libs
parentnet-libs/zeromq: Bumped to v4.1.6 (diff)
downloadgentoo-30624abf0dab82565dfbade028c0c7d7aa56944d.tar.gz
gentoo-30624abf0dab82565dfbade028c0c7d7aa56944d.tar.bz2
gentoo-30624abf0dab82565dfbade028c0c7d7aa56944d.zip
net-libs/zeromq: Restore parallel test restriction
The parallel test restriction (-j1) was lost when the ebuild was bumped to EAPI=6 but is still required. Gentoo-Bug: https://bugs.gentoo.org/597808 Package-Manager: portage-2.3.2
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/zeromq/zeromq-4.1.5-r1.ebuild7
-rw-r--r--net-libs/zeromq/zeromq-4.1.6.ebuild7
2 files changed, 14 insertions, 0 deletions
diff --git a/net-libs/zeromq/zeromq-4.1.5-r1.ebuild b/net-libs/zeromq/zeromq-4.1.5-r1.ebuild
index 6dc347309e20..4101a7ee7771 100644
--- a/net-libs/zeromq/zeromq-4.1.5-r1.ebuild
+++ b/net-libs/zeromq/zeromq-4.1.5-r1.ebuild
@@ -43,6 +43,13 @@ src_configure() {
econf "${myeconfargs[@]}"
}
+src_test() {
+ # Restricting to one job because multiple tests are using the same port.
+ # Upstream knows the problem and says it doesn't support parallel test
+ # execution, see ${S}/INSTALL.
+ emake -j1 check
+}
+
src_install() {
default
prune_libtool_files
diff --git a/net-libs/zeromq/zeromq-4.1.6.ebuild b/net-libs/zeromq/zeromq-4.1.6.ebuild
index 6dc347309e20..4101a7ee7771 100644
--- a/net-libs/zeromq/zeromq-4.1.6.ebuild
+++ b/net-libs/zeromq/zeromq-4.1.6.ebuild
@@ -43,6 +43,13 @@ src_configure() {
econf "${myeconfargs[@]}"
}
+src_test() {
+ # Restricting to one job because multiple tests are using the same port.
+ # Upstream knows the problem and says it doesn't support parallel test
+ # execution, see ${S}/INSTALL.
+ emake -j1 check
+}
+
src_install() {
default
prune_libtool_files