summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-11-09 09:57:38 +0100
committerPacho Ramos <pacho@gentoo.org>2016-11-09 09:59:13 +0100
commit36e5e1c99c34d5b13bf4ef43faadae0c1059ab56 (patch)
treef09c4f467c56d488cf070e15caf84d84d2b0d169 /net-libs
parenttargets/desktop/gnome/package.use: drop unneeded restrictions that can also l... (diff)
downloadgentoo-36e5e1c99c34d5b13bf4ef43faadae0c1059ab56.tar.gz
gentoo-36e5e1c99c34d5b13bf4ef43faadae0c1059ab56.tar.bz2
gentoo-36e5e1c99c34d5b13bf4ef43faadae0c1059ab56.zip
net-libs/liboauth: Version bump
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/liboauth/Manifest1
-rw-r--r--net-libs/liboauth/liboauth-1.0.3.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/net-libs/liboauth/Manifest b/net-libs/liboauth/Manifest
index 37cf335fb29d..d83b9c65936e 100644
--- a/net-libs/liboauth/Manifest
+++ b/net-libs/liboauth/Manifest
@@ -1 +1,2 @@
DIST liboauth-1.0.1.tar.gz 501706 SHA256 5087d32fe1db7b588246a7de64fc0c2464c95efdebb2c7fe6f482d9b00e68d8b SHA512 5d84699ece179a3b17eae8b7113eeadd7bd24df953f7070a6a0e303923b1661d82174894bf64ef6abc6dc344042013256fb2b1ab4fae12ab2778fa15446aa06c WHIRLPOOL 41b83bfc578b74c65018df7a73ba58695352a6e9e53a8a69434dc033c8bea1664417b2e3691dd2f1dd99ce2d55d48bde0fb4d29727294f59b5436720294236ed
+DIST liboauth-1.0.3.tar.gz 504950 SHA256 0df60157b052f0e774ade8a8bac59d6e8d4b464058cc55f9208d72e41156811f SHA512 5a13818dbb3e0df76f7a3fde451eff4f90c9bebfe2076a294921af0c07c2b0789f717f0f862ac6961562d4227e016dc198ddd7efb9c7ac599c3bfbcdb2ac33fa WHIRLPOOL 98d9771a5e8a42ed7781a9f8fbcbdf4dd8e04077028855c07f8722de230be829d66a142e56ff85f88e0db20791b92ece18169b5a49deb1c28f3350ef90a9219c
diff --git a/net-libs/liboauth/liboauth-1.0.3.ebuild b/net-libs/liboauth/liboauth-1.0.3.ebuild
new file mode 100644
index 000000000000..e2a7e7e008b8
--- /dev/null
+++ b/net-libs/liboauth/liboauth-1.0.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="C library implementing the OAuth secure authentication protocol"
+HOMEPAGE="http://liboauth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 MIT )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+IUSE="curl doc bindist +nss"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.0.1-doxygen-out-of-tree.patch )
+REQUIRED_USE="bindist? ( nss )"
+
+CDEPEND="
+ nss? ( dev-libs/nss
+ curl? ( || ( net-misc/curl[ssl,curl_ssl_nss] net-misc/curl[-ssl] ) )
+ )
+
+ !nss? ( dev-libs/openssl
+ curl? ( || ( net-misc/curl[ssl,curl_ssl_openssl] net-misc/curl[-ssl] ) )
+ )
+
+ net-misc/curl
+"
+
+RDEPEND="${CDEPEND}"
+
+DEPEND="${CDEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ media-fonts/freefont
+ )
+ virtual/pkgconfig"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ $(use_enable !curl curl)
+ $(use_enable curl libcurl)
+ $(use_enable nss)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ if use doc ; then
+ # make sure fonts are found
+ export DOTFONTPATH="${EPREFIX}"/usr/share/fonts/freefont-ttf
+ autotools-utils_src_compile dox
+ fi
+}
+
+DOCS=( AUTHORS ChangeLog LICENSE.OpenSSL README )
+
+src_install() {
+ use doc && HTML_DOCS=("${BUILD_DIR}"/doc/html/)
+
+ autotools-utils_src_install
+}