summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPPed72 <paolo.pedroni@iol.it>2016-05-02 16:04:58 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-05-20 07:44:07 +0000
commit40dd89248e1bbcddf04ac23bbca438a6508980b6 (patch)
tree9e010dd829689c4d943bed77244425a697e673c9 /net-libs
parentdev-vcs/git: Removed old. (diff)
downloadgentoo-40dd89248e1bbcddf04ac23bbca438a6508980b6.tar.gz
gentoo-40dd89248e1bbcddf04ac23bbca438a6508980b6.tar.bz2
gentoo-40dd89248e1bbcddf04ac23bbca438a6508980b6.zip
net-libs/rb_libtorrent: fix miscellaneous issues
Gentoo-Bug: https://bugs.gentoo.org/581274 Closes: https://github.com/gentoo/gentoo/pull/1394 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-1.0.9-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-1.0.9-r1.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-1.0.9-r1.ebuild
index 9476aa4b2b30..6a517b90ea42 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-1.0.9-r1.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-1.0.9-r1.ebuild
@@ -43,6 +43,10 @@ RESTRICT="test"
src_prepare() {
default
+ # make sure lib search dir points to the main `S` dir and not to python copies
+ sed -i "s|-L[^ ]*/src/\.libs|-L${S}/src/.libs|" \
+ -- 'bindings/python/link_flags.in' || die
+
# needed or else eautoreconf fails
mkdir build-aux && cp {m4,build-aux}/config.rpath || die
@@ -80,7 +84,7 @@ src_compile() {
default
python_compile() {
- cd "${BUILD_DIR}/../bindings/python" || return 1
+ cd "${BUILD_DIR}/../bindings/python" || die
distutils-r1_python_compile
}
use python && distutils-r1_src_compile
@@ -92,7 +96,7 @@ src_install() {
default
python_install() {
- cd "${BUILD_DIR}/../bindings/python" || return 1
+ cd "${BUILD_DIR}/../bindings/python" || die
distutils-r1_python_install
}
use python && distutils-r1_src_install