summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2017-03-15 14:29:04 -0700
committerPatrick McLean <chutzpah@gentoo.org>2017-03-15 14:31:11 -0700
commit4618be2a414a5d9f24844e515e775a603d034ccd (patch)
treeb2eb2072fc14cc4c0c3e71e7727d7f40e7060c2f /net-libs
parentapp-backup/restic: bump to 0.5.0 (diff)
downloadgentoo-4618be2a414a5d9f24844e515e775a603d034ccd.tar.gz
gentoo-4618be2a414a5d9f24844e515e775a603d034ccd.tar.bz2
gentoo-4618be2a414a5d9f24844e515e775a603d034ccd.zip
net-libs/rb_libtorrent: Make sure 1.1.2 links against the right version of the library
Also makes sure that we are using the right header files. When building the python bindings, since we are working in a copy of the source tree, rather than the one the lib was built in, it tends to use the installed versions rather the new ones. Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-1.1.2.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-1.1.2.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-1.1.2.ebuild
index a896476e7a5e..c3a54a8c6d7c 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-1.1.2.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-1.1.2.ebuild
@@ -48,7 +48,10 @@ src_prepare() {
# bug 578026
# prepend -L${S}/... to ensure bindings link against the lib we just built
- sed -i -e "s|^|-L${S}/src/.libs |" bindings/python/compile_flags.in || die
+ sed -i -e "s|^|-L${S}/src/.libs |" bindings/python/link_flags.in || die
+
+ # prepend -I${S}/... to ensure bindings use the right headers
+ sed -i -e "s|^|-I${S}/src/include |" bindings/python/compile_flags.in || die
use python && distutils-r1_src_prepare
}