summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-02-28 13:24:17 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-02-28 13:24:17 +0100
commit49cd59447e186ab1049d9d74c4bd70a3dffaaf2a (patch)
tree2f0c249ca09d307af4de7a2773fcb68c17bed804 /net-libs
parentnet-libs/libaccounts-glib: Update Manifest (diff)
downloadgentoo-49cd59447e186ab1049d9d74c4bd70a3dffaaf2a.tar.gz
gentoo-49cd59447e186ab1049d9d74c4bd70a3dffaaf2a.tar.bz2
gentoo-49cd59447e186ab1049d9d74c4bd70a3dffaaf2a.zip
net-libs/libaccounts-glib: Revbump to use correct tarball
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libaccounts-glib/libaccounts-glib-1.21-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-libs/libaccounts-glib/libaccounts-glib-1.21-r2.ebuild b/net-libs/libaccounts-glib/libaccounts-glib-1.21-r2.ebuild
new file mode 100644
index 000000000000..66a39ef7862d
--- /dev/null
+++ b/net-libs/libaccounts-glib/libaccounts-glib-1.21-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils vcs-snapshot
+
+DESCRIPTION="Accounts SSO (Single Sign-On) management library for GLib applications"
+HOMEPAGE="https://01.org/gsso/"
+SRC_URI="https://gitlab.com/accounts-sso/libaccounts-glib/repository/archive.tar.gz?ref=VERSION_${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+"
+
+RESTRICT="test"
+
+DOCS=( AUTHORS NEWS )
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-python \
+ --disable-tests \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}