summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-09-24 10:04:43 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-09-24 10:40:28 +0200
commit4c24d46ed54bd203c0eb5196cf2f0ab632b56fda (patch)
treec2d9daeb3475b4ed1737cd6a0c303b55b6cf4b53 /net-libs
parentnet-misc/sysrepo: Version bump to 2.0.41 (diff)
downloadgentoo-4c24d46ed54bd203c0eb5196cf2f0ab632b56fda.tar.gz
gentoo-4c24d46ed54bd203c0eb5196cf2f0ab632b56fda.tar.bz2
gentoo-4c24d46ed54bd203c0eb5196cf2f0ab632b56fda.zip
net-libs/libnetconf2: Version bump to 2.0.17
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libnetconf2/Manifest1
-rw-r--r--net-libs/libnetconf2/libnetconf2-2.0.17.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-libs/libnetconf2/Manifest b/net-libs/libnetconf2/Manifest
index eb691c561916..a5d07cfd14fd 100644
--- a/net-libs/libnetconf2/Manifest
+++ b/net-libs/libnetconf2/Manifest
@@ -1 +1,2 @@
DIST libnetconf2-2.0.1.tar.gz 292658 BLAKE2B d2821b4b66773b777764f7a453649a7ea60bacc418a8ff5c33e54b244a1f285b84ec8a1cc6d6285ff280c8631d79dfe9db352ad03781a7694762efd8545462ac SHA512 26f0a900387a8dbf5c12136d29529e7aba973dba4e1e3ff091cb70385a686533f041cfe647e273f6188b9494b67f771564b2e32f10e1fc61586112d88837f5c8
+DIST libnetconf2-2.0.17.tar.gz 297682 BLAKE2B f92b006886ed0ba16d65836d4e7fc3d82bd40192e756948f5f7332f215ae3a86b5c173060bb4fa8dda69cb40c6d6fcc49c73d40b38437ddabde3fa0c89d0b0ec SHA512 69a8e3139b9fb0661fc70d619c6005c32935aa86847812211b9846dbf60e664c9616848d8874ecd640d60ab316e75920a9e28a22864cb4dfa9b4aa4b5acbfcbc
diff --git a/net-libs/libnetconf2/libnetconf2-2.0.17.ebuild b/net-libs/libnetconf2/libnetconf2-2.0.17.ebuild
new file mode 100644
index 000000000000..e512eea48386
--- /dev/null
+++ b/net-libs/libnetconf2/libnetconf2-2.0.17.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C library for building NETCONF servers and clients"
+HOMEPAGE="https://github.com/CESNET/libnetconf2"
+SRC_URI="https://github.com/CESNET/libnetconf2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ >=net-libs/libyang-2.0.88:=
+ net-libs/libssh:0=[server]
+ virtual/libcrypt:="
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_VALGRIND_TESTS=OFF
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ cmake_src_install
+
+ use doc && dodoc -r doc/.
+}