summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-11-14 20:56:31 +0100
committerJeroen Roovers <jer@gentoo.org>2016-11-14 20:56:31 +0100
commit4e8593b96bccbd718fa152ca4999aafa34db70a9 (patch)
tree02ec810bf6208190195e194841a3f9965295badb /net-libs
parentdev-python/cryptography: bump 1.5.3-r1, eapi update, fix test on first install (diff)
downloadgentoo-4e8593b96bccbd718fa152ca4999aafa34db70a9.tar.gz
gentoo-4e8593b96bccbd718fa152ca4999aafa34db70a9.tar.bz2
gentoo-4e8593b96bccbd718fa152ca4999aafa34db70a9.zip
net-libs/libssh2: Drop upstream patch (bug #599716 by Tomáš Mózes). Fix various issues.
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libssh2/libssh2-9999.ebuild29
1 files changed, 16 insertions, 13 deletions
diff --git a/net-libs/libssh2/libssh2-9999.ebuild b/net-libs/libssh2/libssh2-9999.ebuild
index 29287af83239..2ea9ae87d0b6 100644
--- a/net-libs/libssh2/libssh2-9999.ebuild
+++ b/net-libs/libssh2/libssh2-9999.ebuild
@@ -2,12 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
+inherit autotools git-r3 multilib-minimal
-AUTOTOOLS_AUTORECONF=true
EGIT_REPO_URI="https://github.com/libssh2/libssh2"
-inherit autotools-multilib git-r3
-
DESCRIPTION="Library implementing the SSH2 protocol"
HOMEPAGE="http://www.libssh2.org/"
SRC_URI=""
@@ -23,26 +21,31 @@ DEPEND="
libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
)
gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
- zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+"
RDEPEND="${DEPEND}"
DOCS=( README )
-PATCHES=( "${FILESDIR}"/${PN}-1.8.0-libgcrypt-prefix.patch )
-
src_prepare() {
+ default
+
sed -i -e 's|mansyntax.sh||g' tests/Makefile.am || die
ln -s ../src/libssh2_config.h.in example/libssh2_config.h.in || die
- autotools-multilib_src_prepare
+
+ eautoreconf
}
multilib_src_configure() {
# Disable tests that require extra permissions (bug #333319)
use test && local -x ac_cv_path_SSHD=
- local myeconfargs=(
- $(use_with zlib libz)
- $(usex gcrypt --with-libgcrypt --with-openssl)
- )
- autotools-utils_src_configure
+ local crypto
+ if use gcrypt; then
+ crypto=libgcrypt
+ else
+ crypto=openssl
+ fi
+
+ ECONF_SOURCE="${S}" econf --with-crypto=${crypto}
}