summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-05-29 23:03:21 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-05-29 23:03:38 +0200
commit5888047bd739f6ab3fc8aaca8c7ab3d03d436f0e (patch)
treef4076aca82d48e7d79888ffea8a6fbb0df0d1797 /net-libs
parentwww-apache/mod_gnutls: Bump to version 0.7.5 (diff)
downloadgentoo-5888047bd739f6ab3fc8aaca8c7ab3d03d436f0e.tar.gz
gentoo-5888047bd739f6ab3fc8aaca8c7ab3d03d436f0e.tar.bz2
gentoo-5888047bd739f6ab3fc8aaca8c7ab3d03d436f0e.zip
net-libs/nghttp2: Bump to version 1.11.1
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.11.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 890731af1007..4586449ad409 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1,3 +1,4 @@
DIST nghttp2-1.10.0.tar.gz 2086580 SHA256 192dc031e71e182240079befae9db7e64c9951da3a83c7a438f57cf76145b6a8 SHA512 4341f76ead38ba30e0dfda492e2e0f4c842f453e235fa90ee55b1e556092828236f21c6b212d0099cea005f149e4be3e63ad007009dd5228999101e563009a6f WHIRLPOOL 603391b0d15883cd9db734a0e4bb7d994c17ae4209d5251504e29cc59e0ccf67488b9340acefdb6d6603e9e7d3b0a0491ed18330edce4d20adb0ed19ffc5b975
DIST nghttp2-1.11.0.tar.gz 2091800 SHA256 412d751a1a4440bcccea22f239ba15b5c4a378f5957e106d7445db8f48e1f1f8 SHA512 833f04feea30acea05715cb329c1b24722686b866f0e4988588548b8bbfd7a478f32e8a816172b0870e50bef0b2eca9108bdb99ca1b39be04e247f1d0d375781 WHIRLPOOL bf0deea50d03cf16b480dcca602cf588e0832f3a25e097394460805369c3b8cc480bb37cb19e6ffd8ae24ca1d50b1497cc0cd232972733981293bf8b841e03ba
+DIST nghttp2-1.11.1.tar.gz 2087525 SHA256 6a920d3d6b21f6f7e3aa0061f187bfd0cbf35c3cd2b61cd3fce0af896609b877 SHA512 b65409c6c3566c1f8021fdf5f52366ba834b92062a3a0f507a390e4f46b77ed44f2a03409feba2932bf6278cc1a7b2a86f993e23ee575f9818e0126d7a5b7d06 WHIRLPOOL a57496fffc2a8a9019838ae3a3430c442af371609adcb7ec6610abf92937bf7f58763aff685fbfe0e2d1028410f1c47a752d9ae2a7308c4ba7b95ed4707be938
DIST nghttp2-1.7.1.tar.gz 1993320 SHA256 d83858464c03555828bb603288b66a48680bf164b376d2459a5407c102098a14 SHA512 3a71153d2b30a69e79115402b7db9a04bc812025ccb67b918079f33690f18eb5b286095b8bc161df91abf6466b6bb822ecc13c49bee54265a06ba9ab7c289b54 WHIRLPOOL 41d0afd43878029069d2c339e22b8aec77fedbd1b0fb45da96b9592525c760731e2eec567999af704d63cf94c913b1d0c52063380e69170e1f2d2b928c1d70f3
diff --git a/net-libs/nghttp2/nghttp2-1.11.1.ebuild b/net-libs/nghttp2/nghttp2-1.11.1.ebuild
new file mode 100644
index 000000000000..7d892241bc29
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.11.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: Add python support.
+
+EAPI=6
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+RDEPEND="
+ cxx? ( dev-libs/boost:=[${MULTILIB_USEDEP},threads] )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc )
+ utils? (
+ >=dev-libs/libev-4.15
+ !libressl? ( >=dev-libs/openssl-1.0.2:0[-bindist] )
+ libressl? ( dev-libs/libressl )
+ >=sys-libs/zlib-1.2.3
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-examples \
+ --disable-failmalloc \
+ --disable-werror \
+ --without-cython \
+ --disable-python-bindings \
+ --without-spdylay \
+ $(use_enable cxx asio-lib) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable hpack-tools) \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(multilib_native_use_enable utils app) \
+ $(multilib_native_use_with jemalloc) \
+ $(multilib_native_use_with xml libxml2)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}