summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-12-23 12:43:03 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-12-23 12:43:15 +0100
commit64e5dcc1fb5ef6efa504ddf2330c2792dbed8925 (patch)
tree748f7571e5163825c7cb52b10b39f9bac350d7fe /net-libs
parentsys-devel/gdb: bump up to 8.2.1 (diff)
downloadgentoo-64e5dcc1fb5ef6efa504ddf2330c2792dbed8925.tar.gz
gentoo-64e5dcc1fb5ef6efa504ddf2330c2792dbed8925.tar.bz2
gentoo-64e5dcc1fb5ef6efa504ddf2330c2792dbed8925.zip
net-libs/libetpan: Bump to version 1.9.2
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libetpan/Manifest1
-rw-r--r--net-libs/libetpan/libetpan-1.9.2.ebuild76
-rw-r--r--net-libs/libetpan/metadata.xml1
3 files changed, 78 insertions, 0 deletions
diff --git a/net-libs/libetpan/Manifest b/net-libs/libetpan/Manifest
index de46a350d8f0..9cf03ab661ea 100644
--- a/net-libs/libetpan/Manifest
+++ b/net-libs/libetpan/Manifest
@@ -1,2 +1,3 @@
DIST libetpan-1.8.tar.gz 6188927 BLAKE2B 730d9fc545ea2fbd4dbc0eaf3cdbd0540ec85984dee5448c5f22c83ad12e568a9e066e53734da96ef6a9c77942e5aea2eb241c2228f0ca7577755e67646aa589 SHA512 a5e97998803cc56dbd54356153c8579b52a9675fe95fbf642c3158215428d9d2cb30c4e0060c5f4dd760634fff5b1c2a32ce4bb70a5f2bc6398a071ce95e1efd
DIST libetpan-1.9.1.tar.gz 6189971 BLAKE2B d6cffd9c333c76451d7ac26e978e09b7f1a0b225ef1f318c80f28fe00047c523f2bba32cef5892e452bc84593ce0d635a4cd075e32575c812ff853d0932b01f9 SHA512 1dd72644672e15eecc9883ffb4b29ef34d4355c55aec950cac44e7b59f252d9355f37ef0ad37007c89728c09e057144b4c3b853496a011d693598b6027356286
+DIST libetpan-1.9.2.tar.gz 6191522 BLAKE2B a5b3b93c94596d64b49150680a2599c930b5f010d29be7fbd325e43ba82b8d61032bae65155d2c5e0e2bbcd219db3d916b10a6ce5a98df2ac31fb88811491d71 SHA512 3e2e1de77fae2212374e909d15ed8564eee90883c38fee0ca69f58785733b1ac2df848da1bda6f55577d647e0ad27bc3057199e70b6ef01f2a7e2823b24113ba
diff --git a/net-libs/libetpan/libetpan-1.9.2.ebuild b/net-libs/libetpan/libetpan-1.9.2.ebuild
new file mode 100644
index 000000000000..d364a29f58e9
--- /dev/null
+++ b/net-libs/libetpan/libetpan-1.9.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A portable, efficient middleware for different kinds of mail access"
+HOMEPAGE="http://libetpan.sourceforge.net/"
+SRC_URI="https://github.com/dinhviethoa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="berkdb gnutls ipv6 liblockfile libressl lmdb sasl ssl static-libs"
+
+# BerkDB is only supported up to version 6.0
+DEPEND="sys-libs/zlib
+ !lmdb? ( berkdb? ( <sys-libs/db-6.1:= ) )
+ lmdb? ( dev-db/lmdb )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ )
+ sasl? ( dev-libs/cyrus-sasl:2 )
+ liblockfile? ( net-libs/liblockfile )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-nonnull.patch
+)
+
+pkg_setup() {
+ if use gnutls && ! use ssl ; then
+ ewarn "You have \"gnutls\" USE flag enabled but \"ssl\" USE flag disabled!"
+ ewarn "No ssl support will be available in ${PN}."
+ fi
+
+ if use berkdb && use lmdb ; then
+ ewarn "You have \"berkdb\" _and_ \"lmdb\" USE flags enabled."
+ ewarn "Using lmdb as cache DB!"
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # in Prefix emake uses SHELL=${BASH}, export CONFIG_SHELL to the same so
+ # libtool recognises it as valid shell (bug #300211)
+ use prefix && export CONFIG_SHELL=${BASH}
+ local myeconfargs=(
+ # --enable-debug simply injects "-O2 -g" into CFLAGS
+ --disable-debug
+ $(use_enable berkdb db)
+ $(use_enable ipv6)
+ $(use_enable liblockfile lockfile)
+ $(use_enable lmdb)
+ $(use_enable static-libs static)
+ $(use_with sasl)
+ $(usex ssl "$(use_with gnutls) $(use_with !gnutls openssl)" '--without-gnutls --without-openssl')
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
+}
diff --git a/net-libs/libetpan/metadata.xml b/net-libs/libetpan/metadata.xml
index 4161e28785b7..8c89a487037e 100644
--- a/net-libs/libetpan/metadata.xml
+++ b/net-libs/libetpan/metadata.xml
@@ -13,6 +13,7 @@
</longdescription>
<use>
<flag name="liblockfile">Enable support for liblockfile library</flag>
+ <flag name="lmdb">Use <pkg>dev-db/lmdb</pkg> as cache DB</flag>
</use>
<upstream>
<remote-id type="github">dinhviethoa/libetpan</remote-id>