summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-07-26 10:36:38 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-07-26 11:50:51 +0200
commit6663362baef55be4f8cc25a3c7337a83da4f4442 (patch)
tree5441c25bcbd6d3c33611c93971af8502281ce215 /net-libs
parentsys-libs/uid_wrapper: Bump to version 1.2.4 (diff)
downloadgentoo-6663362baef55be4f8cc25a3c7337a83da4f4442.tar.gz
gentoo-6663362baef55be4f8cc25a3c7337a83da4f4442.tar.bz2
gentoo-6663362baef55be4f8cc25a3c7337a83da4f4442.zip
net-libs/gsoap: Bump to version 2.8.50
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gsoap/Manifest1
-rw-r--r--net-libs/gsoap/gsoap-2.8.50.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/net-libs/gsoap/Manifest b/net-libs/gsoap/Manifest
index 7b7e808e155c..137ef2c2caa9 100644
--- a/net-libs/gsoap/Manifest
+++ b/net-libs/gsoap/Manifest
@@ -1,3 +1,4 @@
DIST gsoap_2.8.40.zip 36317175 SHA256 54ef56d9c55a6a7a00ae57f8cb0b3266af1b26e623070be2ef20833626157f77 SHA512 fc26899e780a7d797544f21aa7beaabc6c1507b7097c4a229a641e4be763733a40e96ce0d5181024eae19653de9513a5b35d51c8b12e85078423e30d0b898a6f WHIRLPOOL 6f795590a5b1e36d796200e3669b3a2aa45c016aa3acaae6291c09543422530a12e977a159a2f892b328cd7813633f41966432e75fd36268bfe4c6d9d1bb6fbf
DIST gsoap_2.8.48.zip 33970070 SHA256 3e7a77a9a9eddc153e0abe2b4983995ac9096df2ade9ff296b472018cdf3b103 SHA512 955e87110c038aad9019a090603dc1ade78a0f84f238d46c03a7d350ad7d4c2b779aea3d16d1bd298336d1b3daa6b8ce399d56ade5dd412b910ebc56b66d305f WHIRLPOOL 28a7800b5e9b695fe663b8497ef76cde0b7a9e7c200976ef9e7b3a624a9dc770f54f63648fabddfe34e050dca51e46b54571afbc9295ccae1a0293038d2cfc4d
DIST gsoap_2.8.49.zip 34679651 SHA256 520909edb975ec7fc63aa1b404993a79c1b8f6a0d80bca588c03cfa5fec12410 SHA512 0e576584aa7743365edac9165eadf233fedf08cbbe70224676f9ce88bc42ae3ace13c75c78f9864f234e406c6e58f1fcdee0a9391215f76f086422ef0ac86ea0 WHIRLPOOL e2fa93454d93f6942fd12370d00aaaad110b58cdce68a7adecffba247bc8b89da2ad0fb8074c0da8b873499af1b8f398f19ffafddf26a8e6d0704028518307b3
+DIST gsoap_2.8.50.zip 34688187 SHA256 d1225f297963d1336ffaa7557990a2a0c8c7700774baa107ecb5467bfc0a265a SHA512 45bbff06083971152054571749fc7dc84962ace550154399590d8b697f0cf702c1614cbfb9f9cd23bc87b3812817abfdcaa6fc210c5daa5e8197493ce0e52a72 WHIRLPOOL f56d19091bdc69cf89a4c11183d946f3b26cc83d132387c9a0771821427e42ed6dc01eaefac15bd9d5f56f126948275bff3fd0b5eb39aa4b462227d041d57c7d
diff --git a/net-libs/gsoap/gsoap-2.8.50.ebuild b/net-libs/gsoap/gsoap-2.8.50.ebuild
new file mode 100644
index 000000000000..aef077767cc0
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.50.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK for SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 libressl gnutls +ssl"
+
+RDEPEND="
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ # Fix Pre-ISO headers
+ eapply "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ # enable shared libs https://bugs.gentoo.org/583398
+ eapply "${FILESDIR}/${PN}-2.7.40-shared_libs.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+ use ssl || myconf+=( --disable-ssl )
+ use gnutls && myconf+=( --enable-gnutls )
+ use ipv6 && myconf+=( --enable-ipv6 )
+ econf \
+ ${myconf[@]} \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.md
+
+ prune_libtool_files --all
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o || die
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}