summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-10-07 20:51:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-10-07 21:56:39 +0200
commit6a2949340085577409c79377b58a1661d78b1f78 (patch)
tree93e7c4eab647385400c94152ddb25b367b3baaf4 /net-libs
parentnet-irc/konversation: 21.08.2 version bump (diff)
downloadgentoo-6a2949340085577409c79377b58a1661d78b1f78.tar.gz
gentoo-6a2949340085577409c79377b58a1661d78b1f78.tar.bz2
gentoo-6a2949340085577409c79377b58a1661d78b1f78.zip
net-libs/libktorrent: 21.08.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libktorrent/Manifest1
-rw-r--r--net-libs/libktorrent/libktorrent-21.08.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/libktorrent/Manifest b/net-libs/libktorrent/Manifest
index 70eea63f0d38..3034f3cfba27 100644
--- a/net-libs/libktorrent/Manifest
+++ b/net-libs/libktorrent/Manifest
@@ -1,2 +1,3 @@
DIST libktorrent-21.04.3.tar.xz 607516 BLAKE2B 5dfea2102fc865d61f2ebf2b1f7045c7ce0f542830f9c7e511d5139f910ff3797a949f85a593a17c56287c3433c086a198f96353a61a4cfc923d96aa30ab4545 SHA512 2c8ee156b0b1e51b96b2670c5fe3f00aa131a34bcebdfdd69898a723fd01a8d2da52a94a1914c13e82b7362a71beaefc03b27eb450dbc84bc43953771bf9b886
DIST libktorrent-21.08.1.tar.xz 606896 BLAKE2B 7a3f58d1d559b0c6376b65fcde7a1a4f76377424dc5c9b2dd07db7af100bcaaa5c859eae4d5247303007fd8f8d452e5cc8b64901c6e9327c0579ff2419984d04 SHA512 a0ab0a5eae08d0ef51772c9284a2041ad8aee2df9158830e62b2b8db428df005293bd3a9af169c4120a21c514e700c84795abc4dd843d27598ace0761986d7c2
+DIST libktorrent-21.08.2.tar.xz 607048 BLAKE2B fe095e15c0b3bb522a9d7b22e03962051b2314696fc25744caa717af60ec0484f112f61213babd72d267420c6074b7c735dedae0d27f48a6ea5b41ed35e9b9b6 SHA512 84d3e59b381d7bbb4515ae4bc989110adf955603a9dbf0970ad47311a4e0c3dc4f20e52752e1d3a33374e46353149da88507014fc096f5643691485b55db3781
diff --git a/net-libs/libktorrent/libktorrent-21.08.2.ebuild b/net-libs/libktorrent/libktorrent-21.08.2.ebuild
new file mode 100644
index 000000000000..7c6b14babcfc
--- /dev/null
+++ b/net-libs/libktorrent/libktorrent-21.08.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+KDE_GEAR="true"
+KDE_ORG_CATEGORY="network"
+KFMIN=5.84.0
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="BitTorrent library based on KDE Frameworks"
+HOMEPAGE="https://apps.kde.org/ktorrent/ https://userbase.kde.org/KTorrent"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=app-crypt/qca-2.3.0:2
+ >=dev-libs/gmp-6.0.0a:0=
+ dev-libs/libgcrypt:0=
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/boost-1.71
+"
+RDEPEND="${COMMON_DEPEND}
+ !dev-libs/botan[gmp(-)]
+"
+BDEPEND="sys-devel/gettext"
+
+src_prepare() {
+ ecm_src_prepare
+
+ # Gentoo workaround because gmp.h in MULTILIB_WRAPPED_HEADERS is breaking this
+ sed -i -e "/^find_package/ s/\"\${LibGMP_MIN_VERSION}\" //" \
+ CMakeLists.txt || die
+ sed -i -e "/^find_dependency/ s/ \"@LibGMP_MIN_VERSION@\"//" \
+ KF5TorrentConfig.cmake.in || die
+}
+
+src_test() {
+ # failing network tests
+ local myctestargs=(
+ -E "(fin|packetloss|send|superseedtest|transmit|utppolltest)"
+ )
+
+ ecm_src_test
+}