summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-12-22 08:54:34 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-12-22 08:54:34 +0100
commit6f9e0c089b6ec3c47be4f5b7d56951b14b9284f1 (patch)
treef50a395771ac6c81053423e26935fc22e62d3a4c /net-libs
parentapp-i18n/ibus: drop gnome2_schemas_savelist() at pkg_postrm() (diff)
downloadgentoo-6f9e0c089b6ec3c47be4f5b7d56951b14b9284f1.tar.gz
gentoo-6f9e0c089b6ec3c47be4f5b7d56951b14b9284f1.tar.bz2
gentoo-6f9e0c089b6ec3c47be4f5b7d56951b14b9284f1.zip
net-libs/gnome-online-accounts: version bump to 3.18.3
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gnome-online-accounts/Manifest1
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.18.3.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/net-libs/gnome-online-accounts/Manifest b/net-libs/gnome-online-accounts/Manifest
index d128c14fd806..f3e57e073e29 100644
--- a/net-libs/gnome-online-accounts/Manifest
+++ b/net-libs/gnome-online-accounts/Manifest
@@ -1,2 +1,3 @@
DIST gnome-online-accounts-3.16.4.1.tar.xz 1440252 SHA256 68c688730a4a0be0a29e77106a78681fd0ea2c4e1aabafe4df7e20a22dbdb120 SHA512 3c563f422afc30994f7d3ac1102a3ace3b0c4ae645e76d4e40566a8aa01324f47737d978352a18e51e268ab3d707fc707ce7d5f0c8c281ebe3c9f86042a4f6b9 WHIRLPOOL 4697f67b55a7b85641efeed101afd384e4b19d9c920b871bdfcf0e6058b27850a771ba1da354b33ceab302ec87d4b6ce46a243637e401abc4e85dbcf3e449feb
DIST gnome-online-accounts-3.18.2.1.tar.xz 1474116 SHA256 ca0a9c58ea5ac08437ed68fea9e8c3de69a8804e670ccf5a578c6786096ecfac SHA512 7c3fa120450c0ebce4a424e18475aebf5b93b5dbb52b9cdad70677493975e7b5dae1d5f631e63a4a6a8aebc6da76c1ab4633ad26d51cb531119493ff612467d4 WHIRLPOOL d096e285ef24b0366fa691c383bc0e6c068e118f1f47533f83e46c602f40f3d344dfa3c7f38c3fce013d2b6c9829134734b58db49c45bba802b357f2778fc140
+DIST gnome-online-accounts-3.18.3.tar.xz 1475580 SHA256 bfb983831af8b1fbd81b70befda7683a38f86ca4cc911f763ae31207306e3827 SHA512 8305ee3cafdf81c7b534d76d2f8b92dfc6bd7acfc27cb02f74f901b4513d2742815a377e523b7d767b1a2e26a2899312ed86bd00e1aedc9c7ecff924f4d91bde WHIRLPOOL 62aafdc8ebb33cc6f0353a378330bb1bdbdd364503fdc86f2b79065a1ec5c5c7634dd8268a275b1f10e20fa3a3b8db1d45f159457e3bd7e5b41071e441c28246
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.18.3.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.18.3.ebuild
new file mode 100644
index 000000000000..96e2dc18ce7c
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.18.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
+
+LICENSE="LGPL-2+"
+SLOT="0/1"
+IUSE="gnome +introspection kerberos" # telepathy"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# pango used in goaeditablelabel
+# libsoup used in goaoauthprovider
+# goa kerberos provider is incompatible with app-crypt/heimdal, see
+# https://bugzilla.gnome.org/show_bug.cgi?id=692250
+# json-glib-0.16 needed for bug #485092
+RDEPEND="
+ >=dev-libs/glib-2.35:2
+ >=app-crypt/libsecret-0.5
+ >=dev-libs/json-glib-0.16
+ dev-libs/libxml2:2
+ >=net-libs/libsoup-2.42:2.4
+ net-libs/rest:0.7
+ net-libs/telepathy-glib
+ >=net-libs/webkit-gtk-2.7.2:4
+ >=x11-libs/gtk+-3.11.1:3
+ x11-libs/pango
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )
+ kerberos? (
+ app-crypt/gcr:0=
+ app-crypt/mit-krb5 )
+"
+# telepathy? ( net-libs/telepathy-glib )
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.3
+ >=dev-util/gdbus-codegen-2.30.0
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+# eautoreconf needs gobject-introspection-common, gnome-common
+
+# Due to sub-configure
+QA_CONFIGURE_OPTIONS=".*"
+
+src_configure() {
+ # TODO: Give users a way to set the G/FB/Windows Live secrets
+ # telepathy optional support is really a badly done, bug #494456
+ gnome2_src_configure \
+ --disable-static \
+ --enable-backend \
+ --enable-documentation \
+ --enable-exchange \
+ --enable-facebook \
+ --enable-flickr \
+ --enable-foursquare \
+ --enable-imap-smtp \
+ --enable-lastfm \
+ --enable-media-server \
+ --enable-owncloud \
+ --enable-pocket \
+ --enable-telepathy \
+ --enable-windows-live \
+ $(use_enable kerberos)
+ #$(use_enable telepathy)
+ # gudev & cheese from sub-configure is overriden
+ # by top level configure, and disabled so leave it like that
+}