summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-23 11:21:58 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-23 11:58:35 +0100
commit79c65eedbb50312ae5e6bea68e455a10560b342e (patch)
tree77914cbe49c725a2ee1940db2d9b9bca9a8f60d6 /net-libs
parentapp-editors/amyedit: Fix building with latest glibmm/libsigc++ (diff)
downloadgentoo-79c65eedbb50312ae5e6bea68e455a10560b342e.tar.gz
gentoo-79c65eedbb50312ae5e6bea68e455a10560b342e.tar.bz2
gentoo-79c65eedbb50312ae5e6bea68e455a10560b342e.zip
net-libs/obby: Fix building with latest glibmm/libsigc++, use USE zeroconf instead of avahi (#477620)
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/obby/obby-0.4.8-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/obby/obby-0.4.8-r1.ebuild b/net-libs/obby/obby-0.4.8-r1.ebuild
new file mode 100644
index 000000000000..64a353047593
--- /dev/null
+++ b/net-libs/obby/obby-0.4.8-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic multilib
+
+DESCRIPTION="Library for collaborative text editing"
+HOMEPAGE="http://gobby.0x539.de/"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="ipv6 nls static-libs zeroconf"
+
+RDEPEND="
+ net-libs/net6
+ dev-libs/libsigc++:2
+ zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ append-cxxflags -std=c++11
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_with zeroconf)
+}
+
+src_install() {
+ default
+ use static-libs || rm -f "${D}"/usr/$(get_libdir)/lib${PN}.la
+}