summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-12-21 12:30:00 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-12-21 12:32:14 +0100
commit7e17062f66e0855d8b1501622d7dadc724ec10a6 (patch)
tree498836db76e64623ab5c8c6471299e93be4bdf6d /net-libs
parentnet-libs/socket_wrapper: Bump to version 1.1.9 (diff)
downloadgentoo-7e17062f66e0855d8b1501622d7dadc724ec10a6.tar.gz
gentoo-7e17062f66e0855d8b1501622d7dadc724ec10a6.tar.bz2
gentoo-7e17062f66e0855d8b1501622d7dadc724ec10a6.zip
net-libs/gsoap: Bump to version 2.8.58
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gsoap/Manifest1
-rw-r--r--net-libs/gsoap/gsoap-2.8.58.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/net-libs/gsoap/Manifest b/net-libs/gsoap/Manifest
index 03a490414dcc..81f6896e9cb8 100644
--- a/net-libs/gsoap/Manifest
+++ b/net-libs/gsoap/Manifest
@@ -1,3 +1,4 @@
DIST gsoap_2.8.51.zip 34505931 BLAKE2B 6f2d6ee2bd405054dc75105f42f6edeaa2300f1e7e6bea15f9e8f0dfcc2df56b36cddfc8f0a038b029f36a6dd1fd63f39eadb8d7f363335344eb142ec27be726 SHA512 491e31ce6be02c577b6184335672a0805e2287418a7e26d9b0f009aab8af462ddef7d7a1893dc867db5362c5f2a1e0022d0a45865d81e43286ce16c649da6910
DIST gsoap_2.8.54.zip 34520149 BLAKE2B 8918b9218b1857a520a56bb264b95d9ce1b192e3e0be9d523a1604c5b9b083f9d6370c331708b7700e71f5502e89815173b09ffa1af24cd9fc16e4539095eaa8 SHA512 59e59dbcb0c7b6f13771c0cd26412941da0a15e05c539dcfaa7deecd83e15b50656454daf6c80eefb85e2d8830748a4fd48970e6de68fd1e2b96ce9a7c0d1874
DIST gsoap_2.8.55.zip 32571850 BLAKE2B 6f262c0b65c7704fbf6c0973d766c0cff788745d0f6331afdffc6bbabbbeeea38222f8038d7a96eae63453a721f2b52b1623f4691e7c677489fb8a3c49d80bae SHA512 e0cb6809d5b8e4a068ed937f253844f88d8275e58f7590ca0dd52bede1ea74d5781d35664586f9e29f2e22c508167df8044d45101f0773c9b8d79b80aa188935
+DIST gsoap_2.8.58.zip 32931913 BLAKE2B ab6e1b9f1e3b866199236b471e638a80c3542ce709e5cca75df9b3d5cd06fc498d09e768078a6863c549e721f657723d50bf53274c7d6603da23f1ea7a887879 SHA512 019c428aee0309ac952af349738a062d4e6deae28f2c5d38178bcd2aa3ead76a7a43faf952ca61f15e8928600a46f1a865b7996ded1c32e1749d1036c5354e2b
diff --git a/net-libs/gsoap/gsoap-2.8.58.ebuild b/net-libs/gsoap/gsoap-2.8.58.ebuild
new file mode 100644
index 000000000000..28cf845a3274
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.58.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK for SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 libressl gnutls +ssl"
+
+RDEPEND="
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+"
+
+PATCHES=(
+ # Fix Pre-ISO headers
+ "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ # enable shared libs https://bugs.gentoo.org/583398
+ "${FILESDIR}/${PN}-2.8.52-shared_libs.patch"
+)
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+ use ssl || myconf+=( --disable-ssl )
+ use gnutls && myconf+=( --enable-gnutls )
+ use ipv6 && myconf+=( --enable-ipv6 )
+ econf \
+ ${myconf[@]} \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.md
+
+ prune_libtool_files --all
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o || die
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}