summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-11-23 04:46:09 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-11-23 04:48:19 +1100
commit892812b39d0554daee5eba923cde77e9ca96114d (patch)
treed9b53d07522dc3165443c90207221b4b64192a73 /net-libs
parentprofiles/base: Enable py3.4 on media-libs/lensfun by default (diff)
downloadgentoo-892812b39d0554daee5eba923cde77e9ca96114d.tar.gz
gentoo-892812b39d0554daee5eba923cde77e9ca96114d.tar.bz2
gentoo-892812b39d0554daee5eba923cde77e9ca96114d.zip
net-libs/telepathy-qt: ensure correct version of Qt is used
Package-Manager: portage-2.2.25
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/telepathy-qt/files/telepathy-qt-0.9.6.1-qtpath.patch21
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-0.9.6.1.ebuild1
2 files changed, 22 insertions, 0 deletions
diff --git a/net-libs/telepathy-qt/files/telepathy-qt-0.9.6.1-qtpath.patch b/net-libs/telepathy-qt/files/telepathy-qt-0.9.6.1-qtpath.patch
new file mode 100644
index 000000000000..3753b90ecfac
--- /dev/null
+++ b/net-libs/telepathy-qt/files/telepathy-qt-0.9.6.1-qtpath.patch
@@ -0,0 +1,21 @@
+Ensure that the correct version of Qt is always used.
+
+With the introduction qt-4.8.6, Qt binaries were moved from /usr/bin to
+/usr/$(get_libdir)/qt4/bin, leaving behind in their place symlinks to qtchooser.
+
+There is no guarantee to which version of Qt these symlinks might point, so it
+is necessary to find the correct version explicitly.
+
+Once qmake is found, it is queried for the correct location of all other items.
+
+--- cmake/modules/FindQt.cmake
++++ cmake/modules/FindQt.cmake
+@@ -19,7 +19,7 @@
+ IF(NOT QT5_INSTALLED)
+ IF(NOT QT_QMAKE_EXECUTABLE)
+ FIND_PROGRAM(QT_QMAKE_EXECUTABLE_FINDQT NAMES qmake qmake4 qmake-qt4 qmake5 qmake-qt5
+- PATHS "${QT_SEARCH_PATH}/bin" "$ENV{QTDIR}/bin")
++ PATHS /usr/${CMAKE_INSTALL_LIBDIR}/qt4/bin /usr/bin NO_DEFAULT_PATH)
+ SET(QT_QMAKE_EXECUTABLE ${QT_QMAKE_EXECUTABLE_FINDQT} CACHE PATH "Qt qmake program.")
+ ENDIF(NOT QT_QMAKE_EXECUTABLE)
+
diff --git a/net-libs/telepathy-qt/telepathy-qt-0.9.6.1.ebuild b/net-libs/telepathy-qt/telepathy-qt-0.9.6.1.ebuild
index d920d98d8296..4beccdae47c0 100644
--- a/net-libs/telepathy-qt/telepathy-qt-0.9.6.1.ebuild
+++ b/net-libs/telepathy-qt/telepathy-qt-0.9.6.1.ebuild
@@ -53,6 +53,7 @@ DOCS=( AUTHORS ChangeLog HACKING NEWS README )
PATCHES=(
"${FILESDIR}/${PV}-default-source.patch"
"${FILESDIR}/${PV}-yes-release.patch"
+ "${FILESDIR}/${PN}-0.9.6.1-qtpath.patch"
)
pkg_setup() {