summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-01-30 17:15:40 +0100
committerPacho Ramos <pacho@gentoo.org>2016-01-30 17:15:56 +0100
commita62079ddda10039b692df7a77fb4ec572027b2e5 (patch)
tree54d71e4a85be135fc15a822b0bda671889f8555b /net-libs
parentmedia-sound/qtractor: bump to 0.7.4 (diff)
downloadgentoo-a62079ddda10039b692df7a77fb4ec572027b2e5.tar.gz
gentoo-a62079ddda10039b692df7a77fb4ec572027b2e5.tar.bz2
gentoo-a62079ddda10039b692df7a77fb4ec572027b2e5.zip
net-libs/webkit-gtk: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/webkit-gtk/Manifest1
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.10.7.ebuild263
2 files changed, 264 insertions, 0 deletions
diff --git a/net-libs/webkit-gtk/Manifest b/net-libs/webkit-gtk/Manifest
index 66b49110230a..c0570d325bcc 100644
--- a/net-libs/webkit-gtk/Manifest
+++ b/net-libs/webkit-gtk/Manifest
@@ -1,3 +1,4 @@
DIST webkitgtk-2.10.4.tar.xz 11015164 SHA256 dbf8260da5cac0c74de2d3cce1fe7c519da3cd816a2c769cb6c6d56addd2f055 SHA512 1d1c79fb863be192639304c5616fb875ccfe541617fdc5c973e79d8159131080ba734199959a01760b9d06accaae7e2e87bec3bcc42dcd2e6b0d19a5b82ed039 WHIRLPOOL 60c789cd2802827dfa90a46debe7506c03ee0203ebbe81db53eba87994ea56ec93b1e9b61253e6411e27faca813ebb27d0ca460e980ddf983afc4e53fcb72744
+DIST webkitgtk-2.10.7.tar.xz 10988396 SHA256 990d62c82ed6dede31a6ff0a82d847f16b812842ff3e1093d17113627652864e SHA512 f0d7b303236910d18568ab1e0a522915a70e9d3658537b32ea2c6a42b8b3ece034a292490f7882760338f2afc56468fd7a8ad8659b7afaf87906220a5c815b5b WHIRLPOOL 7cbe8c42e9c245709eee19a9a01f2a4b238596d8119e3420ca750abb3518e1333ff99a596e9f09d511773a964bafed5baa91efca7b711ddc1c91cb601c520328
DIST webkitgtk-2.4.9.tar.xz 9840740 SHA256 afdf29e7828816cad0be2604cf19421e96d96bf493987328ffc8813bb20ac564 SHA512 5dfe5c31e0fcbab5e468a18e08918a439b214dcd620386fa32d35e9110e479b552a4b0b88a1bb8574b34445d5cc5219be349feded32fc1d2791a6c6279d61f98 WHIRLPOOL 26141cd12878bc8136ecffc1636fdcb037f342e5c27c8c557117564af9d1673af84c8c4fd10d3fdbe890bdf183791b18a210f57de9750422959a45c60390076c
DIST webkitgtk-2.8.5.tar.xz 10455256 SHA256 3d1f0c534935f43fd74df90f2648fcee672d60f1f57a30fa557a77891ae04d20 SHA512 b87a4149aa133824c7855d562a872fef9067d8c7a78026b9ec29d9eb0798a4da827aac4a1ec4eb1a117f7ae50b14c415c6f04ba4ddee851cf55e2dc503c3eddb WHIRLPOOL 1bb1c542d73db31985d4afc6a9ab59730118e57f99aba1a8e81820880bf832386f77aee70f4a50cece180fdb905b7aa5a0f08b91a5eb64a77c3ad5dd82792ead
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.10.7.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.10.7.ebuild
new file mode 100644
index 000000000000..749979fc8d93
--- /dev/null
+++ b/net-libs/webkit-gtk/webkit-gtk-2.10.7.ebuild
@@ -0,0 +1,263 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+CMAKE_MAKEFILE_GENERATOR="ninja"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+inherit check-reqs cmake-utils eutils flag-o-matic gnome2 pax-utils python-any-r1 ruby-single toolchain-funcs versionator virtualx
+
+MY_P="webkitgtk-${PV}"
+DESCRIPTION="Open source web browser engine"
+HOMEPAGE="http://www.webkitgtk.org/"
+SRC_URI="http://www.webkitgtk.org/releases/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2+ BSD"
+SLOT="4/37" # soname version of libwebkit2gtk-4.0
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+
+IUSE="aqua coverage doc +egl +geoloc gles2 gnome-keyring +gstreamer +introspection +jit nsplugin +opengl spell wayland +webgl X"
+# seccomp
+
+REQUIRED_USE="
+ geoloc? ( introspection )
+ gles2? ( egl )
+ introspection? ( gstreamer )
+ nsplugin? ( X )
+ webgl? ( ^^ ( gles2 opengl ) )
+ !webgl? ( ?? ( gles2 opengl ) )
+ || ( aqua wayland X )
+"
+
+# Tests fail to link for inexplicable reasons
+# https://bugs.webkit.org/show_bug.cgi?id=148210
+RESTRICT="test"
+
+# use sqlite, svg by default
+# Aqua support in gtk3 is untested
+# Dependencies found at Source/cmake/OptionsGTK.cmake
+RDEPEND="
+ dev-db/sqlite:3=
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/icu-3.8.1-r1:=
+ >=dev-libs/libxml2-2.8:2
+ >=dev-libs/libxslt-1.1.7
+ >=media-libs/fontconfig-2.8:1.0
+ >=media-libs/freetype-2.4.2:2
+ >=media-libs/harfbuzz-0.9.18:=[icu(+)]
+ >=media-libs/libpng-1.4:0=
+ media-libs/libwebp:=
+ >=net-libs/gnutls-3
+ >=net-libs/libsoup-2.42:2.4[introspection?]
+ virtual/jpeg:0=
+ >=x11-libs/cairo-1.10.2:=
+ >=x11-libs/gtk+-3.14:3[introspection?]
+ x11-libs/libnotify
+ >=x11-libs/pango-1.30.0
+
+ aqua? ( >=x11-libs/gtk+-3.14:3[aqua] )
+ egl? ( media-libs/mesa[egl] )
+ geoloc? ( >=app-misc/geoclue-2.1.5:2.0 )
+ gles2? ( media-libs/mesa[gles2] )
+ gnome-keyring? ( app-crypt/libsecret )
+ gstreamer? (
+ >=media-libs/gstreamer-1.2:1.0
+ >=media-libs/gst-plugins-base-1.2:1.0
+ >=media-libs/gst-plugins-bad-1.5.0:1.0[opengl?] )
+ introspection? ( >=dev-libs/gobject-introspection-1.32.0:= )
+ nsplugin? ( >=x11-libs/gtk+-2.24.10:2 )
+ opengl? ( virtual/opengl
+ x11-libs/cairo[opengl] )
+ spell? ( >=app-text/enchant-0.22:= )
+ wayland? ( >=x11-libs/gtk+-3.14:3[wayland] )
+ webgl? (
+ x11-libs/cairo[opengl]
+ x11-libs/libXcomposite
+ x11-libs/libXdamage )
+ X? (
+ x11-libs/cairo[X]
+ >=x11-libs/gtk+-3.14:3[X]
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXrender
+ x11-libs/libXt )
+"
+# Control knob is private and set to off
+# seccomp? ( sys-libs/libseccomp )
+
+# paxctl needed for bug #407085
+# Need real bison, not yacc
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ ${RUBY_DEPS}
+ >=dev-lang/perl-5.10
+ >=app-accessibility/at-spi2-core-2.5.3
+ >=dev-libs/atk-2.8.0
+ dev-libs/hyphen
+ >=dev-util/gtk-doc-am-1.10
+ >=dev-util/gperf-3.0.1
+ >=sys-devel/bison-2.4.3
+ >=sys-devel/flex-2.5.34
+ || ( >=sys-devel/gcc-4.9 >=sys-devel/clang-3.3 )
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ doc? ( >=dev-util/gtk-doc-1.10 )
+ geoloc? ( dev-util/gdbus-codegen )
+ introspection? ( jit? ( sys-apps/paxctl ) )
+ test? (
+ dev-lang/python:2.7
+ dev-python/pygobject:3[python_targets_python2_7]
+ x11-themes/hicolor-icon-theme
+ jit? ( sys-apps/paxctl ) )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] ; then
+ if is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
+ check-reqs_pkg_pretend
+ fi
+
+ if ! test-flag-CXX -std=c++11 ; then
+ die "You need at least GCC 4.9.x or Clang >= 3.3 for C++11-specific compiler flags"
+ fi
+
+ if [[ $(tc-getCXX) == *g++* && $(gcc-version) < 4.9 ]] ; then
+ die 'The active compiler needs to be gcc 4.9 (or newer)'
+ fi
+ fi
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ check-reqs_pkg_setup
+ fi
+
+ [[ ${MERGE_TYPE} = "binary" ]] || python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # https://bugs.gentoo.org/show_bug.cgi?id=555504
+ epatch "${FILESDIR}"/${PN}-2.8.5-fix-ia64-build.patch
+
+ # https://bugs.gentoo.org/show_bug.cgi?id=564352
+ epatch "${FILESDIR}"/${PN}-2.8.5-fix-alpha-build.patch
+
+ # https://bugs.webkit.org/show_bug.cgi?id=148379
+ epatch "${FILESDIR}"/${PN}-2.8.5-webkit2gtkinjectedbundle-j1.patch
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # Respect CC, otherwise fails on prefix #395875
+ tc-export CC
+
+ # Arches without JIT support also need this to really disable it in all places
+ use jit || append-cppflags -DENABLE_JIT=0 -DENABLE_YARR_JIT=0 -DENABLE_ASSEMBLER=0
+
+ # It does not compile on alpha without this in LDFLAGS
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ # ld segfaults on ia64 with LDFLAGS --as-needed, bug #555504
+ use ia64 && append-ldflags "-Wl,--no-as-needed"
+
+ # Sigbuses on SPARC with mcpu and co., bug #???
+ use sparc && filter-flags "-mvis"
+
+ # https://bugs.webkit.org/show_bug.cgi?id=42070 , #301634
+ use ppc64 && append-flags "-mminimal-toc"
+
+ # Try to use less memory, bug #469942 (see Fedora .spec for reference)
+ # --no-keep-memory doesn't work on ia64, bug #502492
+ if ! use ia64; then
+ append-ldflags "-Wl,--no-keep-memory"
+ fi
+ if ! tc-ld-is-gold ; then
+ append-ldflags "-Wl,--reduce-memory-overheads"
+ fi
+
+ # older glibc needs this for INTPTR_MAX, bug #533976
+ if has_version "<sys-libs/glibc-2.18" ; then
+ append-cppflags "-D__STDC_LIMIT_MACROS"
+ fi
+
+ # Multiple rendering bugs on youtube, github, etc without this, bug #547224
+ append-flags $(test-flags -fno-strict-aliasing)
+
+ local ruby_interpreter=""
+
+ if has_version "virtual/rubygems[ruby_targets_ruby23]"; then
+ ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby23)"
+ elif has_version "virtual/rubygems[ruby_targets_ruby22]"; then
+ ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby22)"
+ elif has_version "virtual/rubygems[ruby_targets_ruby21]"; then
+ ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby21)"
+ else
+ ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby20)"
+ fi
+
+ # TODO: Check Web Audio support
+ # should somehow let user select between them?
+ #
+ # FTL_JIT requires llvm
+ local mycmakeargs=(
+ $(cmake-utils_use_enable aqua QUARTZ_TARGET)
+ $(cmake-utils_use_enable test API_TESTS)
+ $(cmake-utils_use_enable doc GTKDOC)
+ $(cmake-utils_use_enable geoloc GEOLOCATION)
+ $(cmake-utils_use_find_package gles2 OpenGLES2)
+ $(cmake-utils_use_enable gles2 GLES2)
+ $(cmake-utils_use_enable gnome-keyring CREDENTIAL_STORAGE)
+ $(cmake-utils_use_enable gstreamer VIDEO)
+ $(cmake-utils_use_enable gstreamer WEB_AUDIO)
+ $(cmake-utils_use_enable introspection)
+ $(cmake-utils_use_enable jit)
+ $(cmake-utils_use_enable nsplugin PLUGIN_PROCESS_GTK2)
+ $(cmake-utils_use_enable spell SPELLCHECK SPELLCHECK)
+ $(cmake-utils_use_enable wayland WAYLAND_TARGET)
+ $(cmake-utils_use_enable webgl WEBGL)
+ $(cmake-utils_use_find_package egl EGL)
+ $(cmake-utils_use_find_package opengl OpenGL)
+ $(cmake-utils_use_enable X X11_TARGET)
+ -DCMAKE_BUILD_TYPE=Release
+ -DPORT=GTK
+ ${ruby_interpreter}
+ )
+ if tc-ld-is-gold ; then
+ mycmakeargs+=( -DUSE_LD_GOLD=ON )
+ else
+ mycmakeargs+=( -DUSE_LD_GOLD=OFF )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_test() {
+ # Prevents test failures on PaX systems
+ use jit && pax-mark m $(list-paxables Programs/*[Tt]ests/*) # Programs/unittests/.libs/test*
+
+ cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # Prevents crashes on PaX systems, bug #522808
+ use jit && pax-mark m "${ED}usr/bin/jsc" "${ED}usr/libexec/webkit2gtk-4.0/WebKitWebProcess"
+ pax-mark m "${ED}usr/libexec/webkit2gtk-4.0/WebKitPluginProcess"
+ use nsplugin && pax-mark m "${ED}usr/libexec/webkit2gtk-4.0/WebKitPluginProcess"2
+}