summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2019-08-05 16:50:44 +0200
committerGuilherme Amadio <amadio@gentoo.org>2019-08-05 16:54:54 +0200
commitb5a7526a34c3cb385caae2e8dcb9b4952a019b6d (patch)
treed398aad97f892a2e278f0e3af8951ad95a95fd87 /net-libs
parentsys-kernel/gentoo-sources: Clean-up old, unsupported 4.14.X version (diff)
downloadgentoo-b5a7526a34c3cb385caae2e8dcb9b4952a019b6d.tar.gz
gentoo-b5a7526a34c3cb385caae2e8dcb9b4952a019b6d.tar.bz2
gentoo-b5a7526a34c3cb385caae2e8dcb9b4952a019b6d.zip
net-libs/xrootd: version bump to 4.10.0
Closes: https://bugs.gentoo.org/689550 Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/xrootd/Manifest1
-rw-r--r--net-libs/xrootd/xrootd-4.10.0.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/net-libs/xrootd/Manifest b/net-libs/xrootd/Manifest
index fab4e769cdf7..e6d48d3c5492 100644
--- a/net-libs/xrootd/Manifest
+++ b/net-libs/xrootd/Manifest
@@ -1,2 +1,3 @@
+DIST xrootd-4.10.0.tar.gz 2532873 BLAKE2B 076c935d969ce7c5de6c5bde447d7579669c2908394318ddf4e2ef2938aa5cfdf36ac0f52771340b1586a1f933316278eff76c8f568c3f2a67c419ad096d1067 SHA512 deb40ed2d751c3e5a8512a85a9fb13c8fc432cda14682adb0755d0da1f95f177115d09df9438de97d224b36d00d487112d4deeba1c3db9382c7a727daf956bc3
DIST xrootd-4.8.3.tar.gz 2390520 BLAKE2B 1b97225c41f6a3a751f55a4d357f53fac2e4cc24f2456962a6d6282b78faaeb844db5d69bff34437acd2c015dbff4a2a5047d6295770abd200d3e5bedd89d4fe SHA512 6f605131be18f35115bf7cf5d829dfd5a36e004ac69aa77dd0cb34ab70f2b89ff07e7b3e3259fe672d81b6241596c78a537de02e5abad4537dc92ae745ae8911
DIST xrootd-4.9.0.tar.gz 2517614 BLAKE2B 5f1ce6f599fdf5b1f9b4fa078d9b306be241757f95e9b5e9bc0a6f06450a21315778428d8c1d1ffd28ef0841bc50fca387036740bb707d9a96b7f07e94e15540 SHA512 a956262a8adae4c9cb9a91275d4207943cf43251fc61ade111c91152c62baf06c1cbdf1d659c6d792703045a4c2a82bac732220ecfd2fa707e445d6fc66ee047
diff --git a/net-libs/xrootd/xrootd-4.10.0.ebuild b/net-libs/xrootd/xrootd-4.10.0.ebuild
new file mode 100644
index 000000000000..d0c6576d614a
--- /dev/null
+++ b/net-libs/xrootd/xrootd-4.10.0.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1 user
+
+DESCRIPTION="Extended ROOT remote file server"
+HOMEPAGE="http://xrootd.org/"
+SRC_URI="http://xrootd.org/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples fuse http kerberos python readline rbd ssl test"
+
+CDEPEND="
+ !<sci-physics/root-5.32[xrootd]
+ sys-libs/zlib
+ fuse? ( sys-fs/fuse:= )
+ kerberos? ( virtual/krb5 )
+ python? ( ${PYTHON_DEPS} )
+ rbd? ( sys-cluster/ceph )
+ readline? ( sys-libs/readline:0= )
+ ssl? ( dev-libs/openssl:0= )
+"
+DEPEND="${CDEPEND}
+ doc? (
+ app-doc/doxygen[dot]
+ python? ( dev-python/sphinx )
+ )
+ test? ( dev-util/cppunit )
+"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+"
+REQUIRED_USE="
+ http? ( kerberos ssl )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+PATCHES=( "${FILESDIR}"/xrootd-4.8.3-crc32.patch )
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrd*-4.so"
+
+pkg_setup() {
+ enewgroup xrootd
+ enewuser xrootd -1 -1 "${EPREFIX}"/var/spool/xrootd xrootd
+ use python && python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CEPH=$(usex rbd)
+ -DENABLE_CRYPTO=$(usex ssl)
+ -DENABLE_FUSE=$(usex fuse)
+ -DENABLE_HTTP=$(usex http)
+ -DENABLE_KRB5=$(usex kerberos)
+ -DENABLE_PYTHON=$(usex python)
+ -DENABLE_READLINE=$(usex readline)
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ doxygen Doxyfile || die
+ if use python; then
+ emake -C bindings/python/docs html
+ fi
+ fi
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doxydoc/html/. )
+ dodoc docs/ReleaseNotes.txt
+ cmake-utils_src_install
+ find "${D}" \( -iname '*.md5' -o -iname '*.map' \) -delete || die
+
+ # base configs
+ insinto /etc/xrootd
+ doins packaging/common/*.cfg
+
+ fowners root:xrootd /etc/xrootd
+ keepdir /var/log/xrootd
+ fowners xrootd:xrootd /var/log/xrootd
+
+ local i
+ for i in cmsd frm_purged frm_xfrd xrootd; do
+ newinitd "${FILESDIR}"/${i}.initd ${i}
+ done
+ # all daemons MUST use single master config file
+ newconfd "${FILESDIR}"/xrootd.confd xrootd
+
+ if use python; then
+ python_optimize "${D}/$(python_get_sitedir)"
+
+ if use doc; then
+ docinto python
+ docompress -x "/usr/share/doc/${PF}/python/html"
+ dodoc -r bindings/python/docs/build/html
+ fi
+ if use examples; then
+ docinto python
+ dodoc -r bindings/python/examples
+ fi
+ fi
+}