summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-15 23:17:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-15 23:32:09 +0200
commitba2bd6037f03559b49ee56462e0ffd0606d71aa8 (patch)
tree0da8b646779e0840e863b5859d880f3af181ce99 /net-libs
parentapp-text/xapian-omega: stable 1.4.4 for ppc64, bug #624912 (diff)
downloadgentoo-ba2bd6037f03559b49ee56462e0ffd0606d71aa8.tar.gz
gentoo-ba2bd6037f03559b49ee56462e0ffd0606d71aa8.tar.bz2
gentoo-ba2bd6037f03559b49ee56462e0ffd0606d71aa8.zip
net-libs/libtorrent-rasterbar: 1.1.5 version bump
Gentoo-bug: CVE-2017-9847 Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtorrent-rasterbar/Manifest1
-rw-r--r--net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.1.5.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/net-libs/libtorrent-rasterbar/Manifest b/net-libs/libtorrent-rasterbar/Manifest
index 067d483624a4..a283a0b1a89f 100644
--- a/net-libs/libtorrent-rasterbar/Manifest
+++ b/net-libs/libtorrent-rasterbar/Manifest
@@ -4,3 +4,4 @@ DIST libtorrent-rasterbar-1.1.1.tar.gz 3641815 SHA256 f70c82367b0980460ef95aff3e
DIST libtorrent-rasterbar-1.1.2.tar.gz 3909420 SHA256 45e55f2374507bb67a9b9125f6b8d1c45e6cd33849c62b1d9cb56657354e359a SHA512 8cbf6b08bb21c6cbc3b5215a74ecdcce81e312484c688f2b20f95b7288d7f154e7f1337dd0c7d213687159d731bd4518166a964d6a1bda47dc2bd46115a55600 WHIRLPOOL ffd8f1afaece5762298fc8d3380ffe23ed79b5eb019e923d92fd408594054c2caf25e01b237b4cdc2c11181d93df6978301eecb44661378dc944dc89b3e6838a
DIST libtorrent-rasterbar-1.1.3.tar.gz 3912760 SHA256 44196a89932c26528f5db19289d0f0f4130730a61dccc61c9f1eac9ad3e881d8 SHA512 c9d45ceed5cb56b0d7eb7961c3e641158738c5587ef921d98c73b4918b6f1ae0b40e50792b5289062267cc023e36aaa1f64f0f58d363f59875864791434229a5 WHIRLPOOL 4feb345444583317541639f8b42a53026b8ee87d7060254c3e32ef50f697f1f37ee678b3529dae7614938b336a6e937bba4c37cd1a62255594ec4b2f97cf5192
DIST libtorrent-rasterbar-1.1.4.tar.gz 3917557 SHA256 ccf42367803a6df7edcf4756d1f7d0a9ce6158ec33b851b3b58fd470ac4eeba6 SHA512 50f5dfffbd9e6ba21dbe328be17962f29088a326c2c2bf177e1137ed2900323b9a5bae75ee63635404928452f206c72dd4f9100438a6b802bd36b11430e51bc3 WHIRLPOOL f1231e97cdaf820910dafbaf83f9edadf3b70a8fadc71b370e9813d9b9893e6ee893fccfc71a20438ca0b138ac9035c220b656843e7af2755451bf6587f07fc5
+DIST libtorrent-rasterbar-1.1.5.tar.gz 3942894 SHA256 103134068389155a0f2bccaca72a57765460eb8188495089dcad280dcf426930 SHA512 d0e7fe944c8a396aaf79ce80c7513be07a855bc8a9eee3bca46ed83d5e190aaa5ea4dc9a8a7208e27e18ae8f15733e6e34eabd375f0bde43d4dc4607840782e7 WHIRLPOOL 1f78afceb67a69418d2afac915616812fe3a223c548ba2baf7e643fc5e63c79bd87998473ac4b6cab6ac0093d7f43ac91bcfba41c9d6ce0fc1ac46914fce74d2
diff --git a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.1.5.ebuild b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.1.5.ebuild
new file mode 100644
index 000000000000..86fa8d7e920c
--- /dev/null
+++ b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.1.5.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads"
+DISTUTILS_OPTIONAL=true
+DISTUTILS_IN_SOURCE_BUILD=true
+
+inherit distutils-r1 eutils versionator
+
+MY_PV=$(replace_all_version_separators _)
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="http://libtorrent.org"
+SRC_URI="https://github.com/arvidn/libtorrent/releases/download/libtorrent-${MY_PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/9"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +dht doc examples libressl python +ssl static-libs test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ virtual/libiconv
+ examples? ( !net-p2p/mldonkey )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+"
+
+src_prepare() {
+ default
+
+ # bug 578026
+ # prepend -L${S}/... to ensure bindings link against the lib we just built
+ sed -i -e "s|^|-L${S}/src/.libs |" bindings/python/link_flags.in || die
+
+ # prepend -I${S}/... to ensure bindings use the right headers
+ sed -i -e "s|^|-I${S}/src/include |" bindings/python/compile_flags.in || die
+
+ use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable debug logging)
+ $(use_enable debug disk-stats)
+ $(use_enable dht dht $(usex debug logging yes))
+ $(use_enable examples)
+ $(use_enable ssl encryption)
+ $(use_enable static-libs static)
+ $(use_enable test tests)
+ --with-libiconv
+ )
+ econf "${myeconfargs[@]}"
+
+ if use python; then
+ python_configure() {
+ econf "${myeconfargs[@]}" \
+ --enable-python-binding \
+ --with-boost-python="${EPYTHON#python}"
+ }
+ distutils-r1_src_configure
+ fi
+}
+
+src_compile() {
+ default
+
+ python_compile() {
+ cd "${BUILD_DIR}/../bindings/python" || die
+ distutils-r1_python_compile
+ }
+ use python && distutils-r1_src_compile
+}
+
+src_install() {
+ use doc && HTML_DOCS+=( "${S}"/docs )
+
+ default
+
+ python_install() {
+ cd "${BUILD_DIR}/../bindings/python" || die
+ distutils-r1_python_install
+ }
+ use python && distutils-r1_src_install
+
+ prune_libtool_files
+}