summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-27 10:08:23 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-27 10:08:23 -0400
commitcd5ee782a0c9ee78660539194d06f3eff2c8368a (patch)
treee3a16deb46fb272cde60d40753dcd3c9d514d151 /net-libs
parentdev-libs/glib: Version bump to 2.68.1 (diff)
downloadgentoo-cd5ee782a0c9ee78660539194d06f3eff2c8368a.tar.gz
gentoo-cd5ee782a0c9ee78660539194d06f3eff2c8368a.tar.bz2
gentoo-cd5ee782a0c9ee78660539194d06f3eff2c8368a.zip
net-libs/glib-networking: Version bump to 2.68.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/glib-networking/Manifest1
-rw-r--r--net-libs/glib-networking/glib-networking-2.68.1.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/net-libs/glib-networking/Manifest b/net-libs/glib-networking/Manifest
index 8162c804a0d8..7d5e76fb8b29 100644
--- a/net-libs/glib-networking/Manifest
+++ b/net-libs/glib-networking/Manifest
@@ -1,2 +1,3 @@
DIST glib-networking-2.66.0.tar.xz 193920 BLAKE2B bba3c74a3676c15fbe3b9cb97aafb3c9320ebb6f7be1479a66cefd233aa5a548a605be74156445e6a54e8cdb307a09e2916f6d8736640ee38fce9ca289de195f SHA512 697798864746b40542873257a789290cacee425467e32c0eb096c87e124b37510753a990ef5d350f1db85c24da88e448bca9d8d8b4308123a74feac299176de5
DIST glib-networking-2.68.0.tar.xz 237992 BLAKE2B dab2b692c48366ba71325e1808d51a1d7614c29c21448f6d95388c262ec7c6d647489be933595d4e38151d1eef70385181d891d6613e6d1a0a2c95b3b0d764e9 SHA512 3961851d1c39352bc6cbacbc966a7ad075467ca17006eca432ea0646b660fed85951951aee72597a8a595420e6160fd91dca612c241a0505f4f0a67922ef1771
+DIST glib-networking-2.68.1.tar.xz 237876 BLAKE2B 11d982a3d65ae5793a3b6c30cf31737ede5879aa3747416253bacc34d62a1ada944a718223300d63a5b37615492929e63c1c0cad6ef34775ee95e49f6769dc04 SHA512 da38b64e6709c864e1c6a60989d86439e0afb1dbf7b7f60a67f58cf430ae354ef9fe7465e74790b0c2827d2f1c39a250db4372d98fab6ab8d73946a7f51e3b22
diff --git a/net-libs/glib-networking/glib-networking-2.68.1.ebuild b/net-libs/glib-networking/glib-networking-2.68.1.ebuild
new file mode 100644
index 000000000000..5d4e94cae8f7
--- /dev/null
+++ b/net-libs/glib-networking/glib-networking-2.68.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson multilib-minimal xdg
+
+DESCRIPTION="Network-related giomodules for glib"
+HOMEPAGE="https://git.gnome.org/browse/glib-networking/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+gnome +libproxy +ssl test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.67.0:2[${MULTILIB_USEDEP}]
+ libproxy? ( >=net-libs/libproxy-0.4.11-r1:=[${MULTILIB_USEDEP}] )
+ >=net-libs/gnutls-3.6.5:=[${MULTILIB_USEDEP}]
+ ssl? ( app-misc/ca-certificates )
+ gnome? ( gnome-base/gsettings-desktop-schemas )
+"
+DEPEND="${RDEPEND}
+ test? ( net-libs/gnutls[pkcs11] )
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )
+"
+
+src_prepare() {
+ xdg_src_prepare
+
+ if ! use test ; then
+ # Don't build tests unconditionally
+ # This is a hack to avoid needing gnutls[pkcs11] when USE=-test
+ # It may become a real runtime dependency in future
+ # Please check!
+ # bug #777462
+ sed -i "/^subdir('tls\/tests')/d" meson.build || die
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dgnutls=enabled
+ -Dopenssl=disabled
+ $(meson_feature libproxy)
+ $(meson_feature gnome gnome_proxy)
+ -Dinstalled_tests=false
+ -Dstatic_modules=false
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_test() {
+ dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ multilib_pkg_postinst() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+
+ multilib_pkg_postrm() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postrm
+}