summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-03-17 13:12:31 -0300
committerMatt Turner <mattst88@gentoo.org>2023-03-17 12:21:15 -0400
commitd14e7193e02165ab952b3c0c482b881f962f5975 (patch)
tree40c84a30fba4e81bee33f1db7134073859bc34fe /net-libs
parentnet-libs/libgssglue: Stabilize 0.7 arm64, #901943 (diff)
downloadgentoo-d14e7193e02165ab952b3c0c482b881f962f5975.tar.gz
gentoo-d14e7193e02165ab952b3c0c482b881f962f5975.tar.bz2
gentoo-d14e7193e02165ab952b3c0c482b881f962f5975.zip
net-libs/glib-networking: Version bump to 2.76.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30183 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/glib-networking/Manifest1
-rw-r--r--net-libs/glib-networking/glib-networking-2.76.0.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/net-libs/glib-networking/Manifest b/net-libs/glib-networking/Manifest
index 828b6478ccb4..edecefee1313 100644
--- a/net-libs/glib-networking/Manifest
+++ b/net-libs/glib-networking/Manifest
@@ -1,2 +1,3 @@
DIST glib-networking-2.74.0.tar.xz 277232 BLAKE2B d0027a3beff276b2d0b008d1ed0bdeef231d8fb03c26c2e301a3eaef76ad4b704a5db36f6265c5516d73c5dbdb98c7c0919b6924038506dad0123f5ec77577b2 SHA512 f266c106f2c9379b95773a852c1b5c62ae1d6a758d25c436c3558f620d8e0a211201b3c4dfd89cdbe28b88430bba0cca621e62c01ea23d473983e203919bb1e6
+DIST glib-networking-2.76.0.tar.xz 280852 BLAKE2B 418d747473054d00c0eb0258538f919ac077728157523a157a6e6c43a4cdd4554411a486dcdc6af05b1ece8b35884e4954a056d5a01c5118a37721c151b77b8b SHA512 dae704ad70312239379e1e66a4171e9315ee44e1785c9cb2563adc3f0bbab43d08a75873bfd2be12e3ed4210d4a7e177c9540815c8eb4bda89032c5354c4be30
DIST glib-networking-2.76.beta.tar.xz 280780 BLAKE2B d64d6de6e43405a16ff54dce5d27d8ca340338c4d8d7d0965f61b6219684e048911bfe1745eb637ddae7a7e8cdbf3122e5a241a50544ba10bf629f237c8b6c9e SHA512 8c5f77a76ae283247c079164c65cd91b7b2f6919efd89fd6393de2926b35845c83f153fab3b0b7ce4d60d0c9495f2f3dee3009fea3d94a69a8bb26337886233d
diff --git a/net-libs/glib-networking/glib-networking-2.76.0.ebuild b/net-libs/glib-networking/glib-networking-2.76.0.ebuild
new file mode 100644
index 000000000000..e251c597d94b
--- /dev/null
+++ b/net-libs/glib-networking/glib-networking-2.76.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson-multilib xdg
+
+DESCRIPTION="Network-related giomodules for glib"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/glib-networking"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+gnome +libproxy +ssl test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.73.3:2[${MULTILIB_USEDEP}]
+ libproxy? ( >=net-libs/libproxy-0.4.16[${MULTILIB_USEDEP}] )
+ >=net-libs/gnutls-3.7.4:=[${MULTILIB_USEDEP}]
+ ssl? ( app-misc/ca-certificates )
+ gnome? ( gnome-base/gsettings-desktop-schemas )
+"
+DEPEND="${RDEPEND}
+ test? ( net-libs/gnutls[pkcs11] )
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )
+"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+
+ if ! use test ; then
+ # Don't build tests unconditionally
+ # This is a hack to avoid needing gnutls[pkcs11] when USE=-test
+ # It may become a real runtime dependency in future
+ # Please check!
+ # bug #777462
+ sed -i "/^subdir('tests')/d" tls/meson.build || die
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dgnutls=enabled
+ -Dopenssl=disabled
+ $(meson_feature !libproxy environment_proxy)
+ $(meson_feature libproxy)
+ $(meson_feature gnome gnome_proxy)
+ -Dinstalled_tests=false
+ -Ddebug_logs=false
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ multilib_pkg_postinst() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+
+ multilib_pkg_postrm() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postrm
+}