summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-02-01 14:40:03 +0800
committerJason Zaman <perfinion@gentoo.org>2019-02-01 20:08:59 +0800
commitd163e6824af6ea0ca145c806115854dd09735fad (patch)
treecc79f7b46997cdcabd0808b41501506b3d8a5c15 /net-libs
parentdev-libs/crc32c: new package (diff)
downloadgentoo-d163e6824af6ea0ca145c806115854dd09735fad.tar.gz
gentoo-d163e6824af6ea0ca145c806115854dd09735fad.tar.bz2
gentoo-d163e6824af6ea0ca145c806115854dd09735fad.zip
net-libs/google-cloud-cpp: bump to 0.5.0
Signed-off-by: Jason Zaman <perfinion@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/google-cloud-cpp/Manifest3
-rw-r--r--net-libs/google-cloud-cpp/files/google-cloud-cpp-0.5.0-openssl.patch13
-rw-r--r--net-libs/google-cloud-cpp/google-cloud-cpp-0.5.0.ebuild63
3 files changed, 79 insertions, 0 deletions
diff --git a/net-libs/google-cloud-cpp/Manifest b/net-libs/google-cloud-cpp/Manifest
index 410732fa271c..98fcedfa01c4 100644
--- a/net-libs/google-cloud-cpp/Manifest
+++ b/net-libs/google-cloud-cpp/Manifest
@@ -1,3 +1,6 @@
DIST google-cloud-cpp-0.2.0.tar.gz 687020 BLAKE2B 45c09c7cb5b9cc93c87e6d1faedf04f29ae81196dda95660abeadeaaf522376b4e50fd42489476c081e8de7336202d3883ab276c0e2334f1ad1b0e4e1f90fdb8 SHA512 ded3b564ef264a8bff4d81b08f2a97462e063127bf75a006bc7b18d18cfaee2f3cbe5957fe2c56cec06da5a7765854444fad8cd5045579c416c5f3de8462382e
+DIST google-cloud-cpp-0.5.0.tar.gz 1050893 BLAKE2B 6e96e2ca3f518f3c417d9d395001a42182aaeacdbbcfedc636387dbccedf5e570367bc66e5b3fecbe53d5b61e51b53709b83da90718826ac643fb2c43c1723c6 SHA512 48c5f4828bc85ae2c4bfe52b5bb51ff5da6a4cd6759f819aefaf9c23d7fffeb0a10390274f0e83f030f66f59a364c05583240e426143073187f104345e0b05d5
+DIST googleapis-6a3277c0656219174ff7c345f31fb20a90b30b97.tar.gz 746503 BLAKE2B c0cba88c19c658ba7e9e65b80557903f8ded280d25438120b32f8c29a714b58a527c9218f0f73b53646949ecc073d873fee712b370b95523bdea5c28747eeb25 SHA512 92795397dfb9a6aa931be7b191ee91f9f2678a7175dea6babf19a50f61923373d288832cf10edf1ff252ca5148fe649c1bf95535e7c21513129495afae4c0ff7
DIST googleapis-79ab27f3b70ebc221e265d2e8ab30a8cc2d21fa2.tar.gz 874997 BLAKE2B c837323124d26364c83dba72d4f73f3147ad117468b271e8d9502991c1f9a7b20d4f5405351147b65e99c57d207a2b8c1471228d2060ad238ade5159be1b009e SHA512 774e56fc30a4daf2e88d8d3b6747c1ac369d016e9d52527565b88d93252a22597339c17e612304f8823867da4b6df4b58a42dc9d4d480fc59962ee5314a85ab8
DIST nlohmann-json-3.1.2-json.hpp 595822 BLAKE2B 510278344a510a516606f84aea53c682a64a7d1f4703e41503a1688e7c62ab1df8f197a697bd1149e958d21ab986d1b42cb78db6261b07239d9587756813acf5 SHA512 05df0ad3338f0bca885c0aa9da523922b99016986a9b01426b13888c0febd83bf1f6f063886f6c75f8a656ef79abac6292fe442dc05b1897d546ba5b70be48a5
+DIST nlohmann-json-3.4.0-json.hpp 705920 BLAKE2B 9a22a6420f818038d8c4b352fb92ff0f0041b76232ef8665686399d184cfc62caffb60b4ccf1d8d33ae428839a70fece959f94795d71803623405d041efc9a13 SHA512 a1bdb4b434ee34cbc360e0203f500b25e15d7e1a6d25ea6e3bd3b56a5e7ec47d8c0bbe074930b7a07d6ceaf2112eefa24da9c1f0595aaf12c88697048238166d
diff --git a/net-libs/google-cloud-cpp/files/google-cloud-cpp-0.5.0-openssl.patch b/net-libs/google-cloud-cpp/files/google-cloud-cpp-0.5.0-openssl.patch
new file mode 100644
index 000000000000..a5579909e8ab
--- /dev/null
+++ b/net-libs/google-cloud-cpp/files/google-cloud-cpp-0.5.0-openssl.patch
@@ -0,0 +1,13 @@
+diff -ur google-cloud-cpp-0.5.0.orig/google/cloud/storage/CMakeLists.txt google-cloud-cpp-0.5.0/google/cloud/storage/CMakeLists.txt
+--- google-cloud-cpp-0.5.0.orig/google/cloud/storage/CMakeLists.txt 2019-01-30 14:01:05.657031402 +0800
++++ google-cloud-cpp-0.5.0/google/cloud/storage/CMakeLists.txt 2019-01-30 14:01:19.969968164 +0800
+@@ -215,9 +215,6 @@
+ Crc32c::crc32c
+ CURL::CURL
+ Threads::Threads
+- OpenSSL::SSL
+- OpenSSL::Crypto
+- ZLIB::ZLIB
+ PRIVATE storage_common_options)
+ target_include_directories(storage_client
+ PUBLIC $<BUILD_INTERFACE:${PROJECT_SOURCE_DIR}>
diff --git a/net-libs/google-cloud-cpp/google-cloud-cpp-0.5.0.ebuild b/net-libs/google-cloud-cpp/google-cloud-cpp-0.5.0.ebuild
new file mode 100644
index 000000000000..a38936afe9c4
--- /dev/null
+++ b/net-libs/google-cloud-cpp/google-cloud-cpp-0.5.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+JSON_VER="3.4.0"
+GOOGLEAPIS_COMMIT="6a3277c0656219174ff7c345f31fb20a90b30b97"
+
+DESCRIPTION="Google Cloud Client Library for C++"
+HOMEPAGE="https://cloud.google.com/"
+SRC_URI="https://github.com/GoogleCloudPlatform/google-cloud-cpp/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/nlohmann/json/releases/download/v${JSON_VER}/json.hpp -> nlohmann-json-${JSON_VER}-json.hpp
+ https://github.com/googleapis/googleapis/archive/${GOOGLEAPIS_COMMIT}.tar.gz -> googleapis-${GOOGLEAPIS_COMMIT}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="test"
+RDEPEND="dev-libs/protobuf
+ net-misc/curl
+ net-libs/grpc"
+DEPEND="${RDEPEND}"
+
+DOCS=( README.md )
+PATCHES=(
+ "${FILESDIR}/google-cloud-cpp-0.5.0-openssl.patch"
+)
+
+src_prepare() {
+ rm -rf "${S}/third_party/googleapis/" || die
+ mv "${WORKDIR}/googleapis-${GOOGLEAPIS_COMMIT}/" "${S}/third_party/googleapis/" || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DGOOGLE_CLOUD_CPP_CRC32C_PROVIDER=package
+ -DGOOGLE_CLOUD_CPP_CURL_PROVIDER=package
+ -DGOOGLE_CLOUD_CPP_GMOCK_PROVIDER=package
+ -DGOOGLE_CLOUD_CPP_GRPC_PROVIDER=pkg-config
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_TESTING=OFF
+ )
+
+ cmake-utils_src_configure
+
+ mkdir -p "${BUILD_DIR}/external/nlohmann_json/src/" || die
+ cp "${DISTDIR}/nlohmann-json-${JSON_VER}-json.hpp" "${BUILD_DIR}/external/nlohmann_json/src/json.hpp" || die
+}
+
+src_test() {
+ # test fails
+ local myctestargs=(
+ -E internal_parse_rfc3339_test
+ )
+
+ cmake-utils_src_test
+}