summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-24 01:57:00 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-24 01:59:32 +0100
commitdfcbe77acfac3074a6761d89900c53ca35c65e7c (patch)
treec57f965f1f6edb82b9127e0066f7a6dc338f2248 /net-libs
parentmail-filter/procmail: revbump to fix longstanding vulnerabilities (diff)
downloadgentoo-dfcbe77acfac3074a6761d89900c53ca35c65e7c.tar.gz
gentoo-dfcbe77acfac3074a6761d89900c53ca35c65e7c.tar.bz2
gentoo-dfcbe77acfac3074a6761d89900c53ca35c65e7c.zip
net-libs/gloox: Bump to version 1.0.22
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gloox/Manifest1
-rw-r--r--net-libs/gloox/gloox-1.0.22.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/gloox/Manifest b/net-libs/gloox/Manifest
index 045a5eb7521c..97e7f315d303 100644
--- a/net-libs/gloox/Manifest
+++ b/net-libs/gloox/Manifest
@@ -1,2 +1,3 @@
DIST gloox-1.0.20.tar.bz2 701114 BLAKE2B d86b4de05a040b4f7fe1200d5863514778197e7e13ee08ebe983a85255065045c47b322ba20fa4ea051049ce609f122c00374cc3188f46c8729ec904da7778eb SHA512 b94269487875ae32631b5b15eeebe3293c6b8ab4080a6e15926c575305841a609a5e4da25bff266806ef4b65c1db14e9a9e5dabf8af8b174773cbdc37cfa12f8
DIST gloox-1.0.21.tar.bz2 716449 BLAKE2B 9728b137b088e3ebd067dd88688474e37ec27108cc87ffe6d2d78b206c3215f36c072e333d04c659e5dc9db43c330bcac7ee7f495208bd8df1bbeb72db1e0792 SHA512 ee2c180e6a6e05955707fdd3e790c4c0e7be46fdf071201abd081b8620e3f664045f000804e1a30bddf8a3324e90f211ce5ee870fd5330ab87979dedfeb45575
+DIST gloox-1.0.22.tar.bz2 722653 BLAKE2B e029930ae51053772d4f7bb0cb0933cb260aacc571a6fab6b78c0e12cb7e119938c742afcc0e1af037a97c293f03b423a626c9b01dc9ce974b922c7e9054bcf2 SHA512 89b51dbee338ef8b234d934a5536a2e5d83d8121fa624e933b63bd15017d60f941781a1045884d0d125f50370ed7857cf4131242d39f6703e72c9cf064691416
diff --git a/net-libs/gloox/gloox-1.0.22.ebuild b/net-libs/gloox/gloox-1.0.22.ebuild
new file mode 100644
index 000000000000..9b02001ae84f
--- /dev/null
+++ b/net-libs/gloox/gloox-1.0.22.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${P/_/-}"
+DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
+HOMEPAGE="https://camaya.net/gloox/"
+SRC_URI="https://camaya.net/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0/17"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~ia64 ~sparc ~x86"
+IUSE="debug gnutls idn libressl ssl static-libs test zlib"
+
+DEPEND="idn? ( net-dns/libidn:= )
+ gnutls? ( net-libs/gnutls )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ )
+ zlib? ( sys-libs/zlib )"
+
+RDEPEND="${DEPEND}"
+
+# GnuTLS checks hang forever
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ # Examples are not installed anyway, so - why should we build them?
+ local myeconfargs=(
+ --without-examples
+ $(usex debug "--enable-debug" '')
+ $(use_enable static-libs static)
+ $(use_with idn libidn)
+ $(use_with gnutls)
+ $(use_with ssl openssl)
+ $(use_with test tests)
+ $(use_with zlib)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}