summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-10-25 09:28:24 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-10-25 09:29:11 +0200
commite25d51269a33c96c319a481bde5c856d63b44609 (patch)
tree150e2db0930c05d113e27533ba62bb282f915f25 /net-libs
parentgames-rpg/runescape-launcher: regenerate Manifest file. (diff)
downloadgentoo-e25d51269a33c96c319a481bde5c856d63b44609.tar.gz
gentoo-e25d51269a33c96c319a481bde5c856d63b44609.tar.bz2
gentoo-e25d51269a33c96c319a481bde5c856d63b44609.zip
net-libs/nghttp2: Bump to version 1.16.0
Package-Manager: portage-2.3.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.16.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index de37ff8ac9d9..72ba6b722b55 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1,4 +1,5 @@
DIST nghttp2-1.10.0.tar.gz 2086580 SHA256 192dc031e71e182240079befae9db7e64c9951da3a83c7a438f57cf76145b6a8 SHA512 4341f76ead38ba30e0dfda492e2e0f4c842f453e235fa90ee55b1e556092828236f21c6b212d0099cea005f149e4be3e63ad007009dd5228999101e563009a6f WHIRLPOOL 603391b0d15883cd9db734a0e4bb7d994c17ae4209d5251504e29cc59e0ccf67488b9340acefdb6d6603e9e7d3b0a0491ed18330edce4d20adb0ed19ffc5b975
DIST nghttp2-1.14.1.tar.gz 2122458 SHA256 1e1d36a7717373daa8f5049b8e1327e72e77acb961424cbd05a6619501374fb9 SHA512 a4ec88fa4636f540a7a15d97b87415be951ce094ec431eec3c54e82fc0da82cb9173dd0167cb5f21fa252554987de3c682a94fd65779c4c73fa0c81995eb3b2e WHIRLPOOL af16f80e23ed02b6120f67052d56223579cacf7bdc24976b0b3a0fc2c5050fe2362615b2f85e2d49893bd8378c34642d0a48c0c3a26e44f8bbdbdb7e119ccd9a
DIST nghttp2-1.15.0.tar.gz 2139639 SHA256 3c8bd105c65d2fe9b582e61adac3f571cf15f547a6d559106979c9019e3b8901 SHA512 898924de5ef139bc55a8f12830cc4950a4821ad7ef2f3c0a840183f5389b9a536ba74389993ef6204d26ed149f81e5ec2bb715d5e9483e2b552b4cd64cd17efe WHIRLPOOL a451bb799adc382f2a4ebf17a174a27241c826bcd7b27021bc6294ef7232ea76e72d8a49690b3b26d560fe03757867d2c943c9bcf6cd484d2b6067dd1acfdf2e
+DIST nghttp2-1.16.0.tar.gz 2150767 SHA256 02b829d8cdb93ed4598e5209d8932bd272f706d3c183787378209f988e01f007 SHA512 9397d584e6062996af01a3c403c637c5ba7ef822d0df1a9ee8066079c00e3bf5171cd5c43cb6a1ef40ce16aac78a73eb89206aa3b61b317b7f81647c36c6e08d WHIRLPOOL af5d92d7e6b2fc146dda2391530e71dbc021749335dc123935b572de25cb2bdf4b37e40f5aa8c5da91a2080e33d35f630c161d1f62a701d410b283bee01e55da
DIST nghttp2-1.7.1.tar.gz 1993320 SHA256 d83858464c03555828bb603288b66a48680bf164b376d2459a5407c102098a14 SHA512 3a71153d2b30a69e79115402b7db9a04bc812025ccb67b918079f33690f18eb5b286095b8bc161df91abf6466b6bb822ecc13c49bee54265a06ba9ab7c289b54 WHIRLPOOL 41d0afd43878029069d2c339e22b8aec77fedbd1b0fb45da96b9592525c760731e2eec567999af704d63cf94c913b1d0c52063380e69170e1f2d2b928c1d70f3
diff --git a/net-libs/nghttp2/nghttp2-1.16.0.ebuild b/net-libs/nghttp2/nghttp2-1.16.0.ebuild
new file mode 100644
index 000000000000..1fae52de3253
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.16.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: Add python support.
+
+EAPI=6
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+RDEPEND="
+ cxx? ( dev-libs/boost:=[${MULTILIB_USEDEP},threads] )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
+ utils? (
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ !libressl? ( >=dev-libs/openssl-1.0.2:0[-bindist,${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-examples \
+ --disable-failmalloc \
+ --disable-werror \
+ --without-cython \
+ --disable-python-bindings \
+ --without-spdylay \
+ $(use_enable cxx asio-lib) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable hpack-tools) \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(multilib_native_use_enable utils app) \
+ $(multilib_native_use_with jemalloc) \
+ $(multilib_native_use_with xml libxml2)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}