summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-01-04 16:23:22 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-04 16:24:59 +0100
commiteeb557c0e6d3955eb98c09fcd3c6d6c42627328b (patch)
tree5d0c416921210dab14f8c9a19aad3a77472de9ea /net-libs
parenteclass/multilib-build: fix ABI matching for ppc-macos (diff)
downloadgentoo-eeb557c0e6d3955eb98c09fcd3c6d6c42627328b.tar.gz
gentoo-eeb557c0e6d3955eb98c09fcd3c6d6c42627328b.tar.bz2
gentoo-eeb557c0e6d3955eb98c09fcd3c6d6c42627328b.zip
net-libs/gsoap: Bump to version 2.8.59
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gsoap/Manifest1
-rw-r--r--net-libs/gsoap/gsoap-2.8.59.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/net-libs/gsoap/Manifest b/net-libs/gsoap/Manifest
index 2794db61de76..22eeccfd4bba 100644
--- a/net-libs/gsoap/Manifest
+++ b/net-libs/gsoap/Manifest
@@ -1,3 +1,4 @@
DIST gsoap_2.8.51.zip 34505931 BLAKE2B 6f2d6ee2bd405054dc75105f42f6edeaa2300f1e7e6bea15f9e8f0dfcc2df56b36cddfc8f0a038b029f36a6dd1fd63f39eadb8d7f363335344eb142ec27be726 SHA512 491e31ce6be02c577b6184335672a0805e2287418a7e26d9b0f009aab8af462ddef7d7a1893dc867db5362c5f2a1e0022d0a45865d81e43286ce16c649da6910
DIST gsoap_2.8.55.zip 32571850 BLAKE2B 6f262c0b65c7704fbf6c0973d766c0cff788745d0f6331afdffc6bbabbbeeea38222f8038d7a96eae63453a721f2b52b1623f4691e7c677489fb8a3c49d80bae SHA512 e0cb6809d5b8e4a068ed937f253844f88d8275e58f7590ca0dd52bede1ea74d5781d35664586f9e29f2e22c508167df8044d45101f0773c9b8d79b80aa188935
DIST gsoap_2.8.58.zip 32931913 BLAKE2B ab6e1b9f1e3b866199236b471e638a80c3542ce709e5cca75df9b3d5cd06fc498d09e768078a6863c549e721f657723d50bf53274c7d6603da23f1ea7a887879 SHA512 019c428aee0309ac952af349738a062d4e6deae28f2c5d38178bcd2aa3ead76a7a43faf952ca61f15e8928600a46f1a865b7996ded1c32e1749d1036c5354e2b
+DIST gsoap_2.8.59.zip 33109898 BLAKE2B d05ddf0c1e24afc03a33592cf8abef6f0bb6c8a8a216aee9ce7614720a8e3cd015f1e03429113ac8bdc05e6b916fee022914db22d0c29b5c9c4d0fb60c549168 SHA512 d43320e6965c3f17d122ea7aeeecbc0b608dac52204e630c3254d32eadd3c93aaca446c92bb439b98207f8560b2ad6bff220c0502b75ebd18b99e37402570624
diff --git a/net-libs/gsoap/gsoap-2.8.59.ebuild b/net-libs/gsoap/gsoap-2.8.59.ebuild
new file mode 100644
index 000000000000..84b2601d54ef
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.59.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK for SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 libressl gnutls +ssl"
+
+RDEPEND="
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+"
+
+PATCHES=(
+ # Fix Pre-ISO headers
+ "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ # enable shared libs https://bugs.gentoo.org/583398
+ "${FILESDIR}/${PN}-2.8.52-shared_libs.patch"
+)
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+ use ssl || myconf+=( --disable-ssl )
+ use gnutls && myconf+=( --enable-gnutls )
+ use ipv6 && myconf+=( --enable-ipv6 )
+ econf \
+ ${myconf[@]} \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.md
+
+ prune_libtool_files --all
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o || die
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}