summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-15 21:09:42 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-15 22:51:56 +0200
commitf7ee786b4173c5077e353a61c9f74462f211dfb6 (patch)
treea3f8860762104f3d87d75f8015e3346177fb6521 /net-libs
parentnet-p2p/ktorrent: EAPI-7 bump, misc upstream fixes (diff)
downloadgentoo-f7ee786b4173c5077e353a61c9f74462f211dfb6.tar.gz
gentoo-f7ee786b4173c5077e353a61c9f74462f211dfb6.tar.bz2
gentoo-f7ee786b4173c5077e353a61c9f74462f211dfb6.zip
net-libs/libktorrent: EAPI-7 bump
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libktorrent/files/libktorrent-2.1-unused-link.patch24
-rw-r--r--net-libs/libktorrent/libktorrent-2.1-r2.ebuild59
2 files changed, 83 insertions, 0 deletions
diff --git a/net-libs/libktorrent/files/libktorrent-2.1-unused-link.patch b/net-libs/libktorrent/files/libktorrent-2.1-unused-link.patch
new file mode 100644
index 000000000000..636c59d1b065
--- /dev/null
+++ b/net-libs/libktorrent/files/libktorrent-2.1-unused-link.patch
@@ -0,0 +1,24 @@
+From e7c4847d9bbdc5d7c7435039aa5088d276ca5bce Mon Sep 17 00:00:00 2001
+From: Jonathan Riddell <jr@jriddell.org>
+Date: Mon, 10 Jun 2019 13:27:29 +0100
+Subject: remove unused link to kcrash, it can be used by the apps which use
+ libktorrent but it needs to be initialised not just arbitrarily linked to
+
+---
+ src/CMakeLists.txt | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index d347e07..1578bf4 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -235,7 +235,6 @@ PRIVATE
+ qca-qt5
+ PUBLIC
+ KF5::Archive
+- KF5::Crash
+ KF5::KIOCore
+ KF5::KIOWidgets
+ KF5::Solid
+--
+cgit v1.1
diff --git a/net-libs/libktorrent/libktorrent-2.1-r2.ebuild b/net-libs/libktorrent/libktorrent-2.1-r2.ebuild
new file mode 100644
index 000000000000..230154addc5c
--- /dev/null
+++ b/net-libs/libktorrent/libktorrent-2.1-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="BitTorrent library based on KDE Frameworks"
+HOMEPAGE="https://kde.org/applications/internet/ktorrent/"
+SRC_URI="mirror://kde/stable/ktorrent/5.1/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+BDEPEND="sys-devel/gettext"
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtxml)
+ app-crypt/qca:2[qt5(+)]
+ >=dev-libs/gmp-6.0.0a:0=
+ dev-libs/libgcrypt:0=
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+"
+RDEPEND="${COMMON_DEPEND}
+ !dev-libs/botan[gmp(-)]
+"
+
+PATCHES=( "${FILESDIR}/${P}-unused-link.patch" )
+
+src_prepare() {
+ kde5_src_prepare
+
+ # Gentoo workaround because gmp.h in MULTILIB_WRAPPED_HEADERS is breaking this
+ sed -i -e "/^find_package/ s/\"\${LibGMP_MIN_VERSION}\" //" \
+ CMakeLists.txt || die
+ sed -i -e "/^find_dependency/ s/ \"@LibGMP_MIN_VERSION@\"//" \
+ KF5TorrentConfig.cmake.in || die
+}
+
+src_test() {
+ # failing network tests
+ local myctestargs=(
+ -E "(fin|packetloss|send|transmit)"
+ )
+
+ kde5_src_test
+}