summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-09-05 09:49:37 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-09-05 09:49:37 +0000
commitdcc51f5cba120faa06e6a7587a1b632bad89ad71 (patch)
tree1781362024dbb44e37a5db185468381cab44b3f4 /net-mail/Freemail/Freemail-9999-r1.ebuild
parentdev-java/osgi-core-api: Remove old. (diff)
downloadgentoo-dcc51f5cba120faa06e6a7587a1b632bad89ad71.tar.gz
gentoo-dcc51f5cba120faa06e6a7587a1b632bad89ad71.tar.bz2
gentoo-dcc51f5cba120faa06e6a7587a1b632bad89ad71.zip
net-mail/Freemail: EAPI 5 bump. Bump bcprov SLOT to 1.38.
Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-mail/Freemail/Freemail-9999-r1.ebuild')
-rw-r--r--net-mail/Freemail/Freemail-9999-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-mail/Freemail/Freemail-9999-r1.ebuild b/net-mail/Freemail/Freemail-9999-r1.ebuild
new file mode 100644
index 000000000000..83ec9f56b1b3
--- /dev/null
+++ b/net-mail/Freemail/Freemail-9999-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+EGIT_REPO_URI="git://github.com/freenet/plugin-Freemail-official.git
+ https://github.com/freenet/plugin-Freemail-official.git"
+EGIT_PROJECT="Freemail/official"
+EANT_BUILD_TARGET="dist"
+inherit eutils git-2 java-pkg-2 java-ant-2
+
+DESCRIPTION="Anonymous IMAP/SMTP e-mail server over Freenet"
+HOMEPAGE="http://www.freenetproject.org/tools.html"
+SRC_URI=""
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+CDEPEND="dev-java/bcprov:1.38
+ net-p2p/freenet"
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+EANT_GENTOO_CLASSPATH="bcprov freenet"
+
+src_prepare() {
+ epatch "${FILESDIR}"/build.patch
+ java-ant_rewrite-classpath
+}
+
+src_install() {
+ java-pkg_dojar dist/"${PN}.jar"
+ dodir /var/freenet/plugins
+ fperms freenet:freenet /var/freenet/plugins
+ dodoc README || die "installation of documentation failed"
+}
+
+pkg_postinst () {
+ #force chmod for previously existing plugins dir owned by root
+ [[ $(stat --format="%U" /var/freenet/plugins) == "freenet" ]] || chown \
+ freenet:freenet /var/freenet/plugins
+ elog "To load Freemail, go to the plugin page of freenet and enter at"
+ elog "Plugin-URL: /usr/share/Freemail/lib/Freemail.jar"
+ elog " This should load the Freemail plugin."
+ elog "Set your email client to IMAP port 3143 and SMTP port 3025 on localhost."
+ elog "To bind freemail to different ports, or to a different freenet node, edit"
+ elog "/var/freenet/globalconfig."
+}