summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-26 00:38:27 +0000
committerSam James <sam@gentoo.org>2023-02-26 00:38:27 +0000
commit6ed4035069c67428c838d34082e65eaccec5ca7e (patch)
tree553161233d0045e70df42855e74328ed5c0fc345 /net-mail/b4
parentdev-ml/ocamlbuild: Stabilize 0.14.2 amd64, #897752 (diff)
downloadgentoo-6ed4035069c67428c838d34082e65eaccec5ca7e.tar.gz
gentoo-6ed4035069c67428c838d34082e65eaccec5ca7e.tar.bz2
gentoo-6ed4035069c67428c838d34082e65eaccec5ca7e.zip
net-mail/b4: add 0.12.1
Closes: https://bugs.gentoo.org/897108 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail/b4')
-rw-r--r--net-mail/b4/Manifest1
-rw-r--r--net-mail/b4/b4-0.12.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/net-mail/b4/Manifest b/net-mail/b4/Manifest
index 9b1ab5a615f6..78a2f73e4e5d 100644
--- a/net-mail/b4/Manifest
+++ b/net-mail/b4/Manifest
@@ -1,2 +1,3 @@
DIST b4-0.10.1.tar.gz 100142 BLAKE2B 81481b835c8fc63df6c78c852344a6daeeba656268b61808fb314b09e45786473b453c5163d2dd7c01604caad4281f7e7712efdb57c0dee2dcf415f0781b4a7b SHA512 6707f4407bfe9b46134c243d18a110150f1647fc12328c8e7fedeb40e404b6bd8662d651479c27145965bffabc3ca2f8498b53e801fc2846116ef101e1974733
+DIST b4-0.12.1.tar.gz 233691 BLAKE2B d10dc969d16722083ab0b79b7a2a26df44dbe2d5a8a804a0339903ff30f2a25a915e7755d4c5a9855d9b3abd8fbd6a3ff3b8034a6679491835446fdd24ee1b0f SHA512 6a7cacfdda6b4c8c3b87554c1b8fc7b2e797ea0b44476943aa6b75a901dc57cc17fab2a584d63c3724967ee8e6d9b3070dea94a6e4df43547a521ba741366032
DIST b4-0.8.0.tar.gz 66882 BLAKE2B 7f93b9ce9f1f448a1b4be94c692ee93912e273c740c41518fdacd515df7038ba140f62712ef7a6df8a946315eb776ebb7e182d71905ca2ff34771525ceefe4c2 SHA512 4696a0164289eb7077d276a3133ba3776bfc3bfa25fd3591da6e932329f1578fcfe9909419426865ba3239c5b0a7b23dbb85df10307210420ac85e399d8fddd9
diff --git a/net-mail/b4/b4-0.12.1.ebuild b/net-mail/b4/b4-0.12.1.ebuild
new file mode 100644
index 000000000000..be2c831b62a5
--- /dev/null
+++ b/net-mail/b4/b4-0.12.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Utility for fetching patchsets from public-inbox"
+HOMEPAGE="https://pypi.org/project/b4/"
+# pypi lacks tests
+SRC_URI="https://git.kernel.org/pub/scm/utils/b4/b4.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/dkimpy-1.0[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-2.1[${PYTHON_USEDEP}]
+ >=dev-python/patatt-0.6[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+ >=dev-vcs/git-filter-repo-2.30[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest